2

Now I can use Super+D to hide all windows. I want to change it to Ctrl+D or something like this. I go to settings and set it:

keyboard settings screenshot

but nothing changes. When I open all shortcuts pressing Super I see that it now shows Ctrl+D but I can hide windows only using the old Super+D. I added "show desktop" button and I tried to reload the computer, but nothing changes.

Edit:

Strange thing: after restarting or logging out ctrl+d shortcut works exactly 1 time. It hides windows, then shows windows, then stops working

3
  • What version of Ubuntu are you using?
    – wjandrea
    Aug 19, 2017 at 17:21
  • I`m using 16.04 Aug 19, 2017 at 17:22
  • Your edit saved my life.
    – arsaKasra
    Oct 18, 2018 at 9:16

2 Answers 2

1

For some reason, Settings (unity-control-center) can't be used to change this shortcut. You have to use CompizConfig Settings Manager (CCSM).

  1. Install CCSM. Run in terminal:

    sudo apt-get install compizconfig-settings-manager
    
  2. Open CCSM

  3. Go to Desktop section → Ubuntu Unity PluginGeneral tab
  4. Change the Show Desktop shortcut

    CCSM screenshot

This is based on Prime624's answer on a related question.

0
0

You just need to log out and back in, or restart the computer.

I've experienced the same thing when changing Super shortcuts. I don't know why exactly it happens, but it seems like changes only take effect when you start a new X session (by logging out and back in).

2
  • Whoops, I may have missed the last sentence in the question. I assume "reload" means "restart", but let me know if I'm wrong.
    – wjandrea
    Aug 19, 2017 at 17:15
  • Strange thing: after restarting or logging out ctrl+d shortcut works exactly 1 time. It hides windows, then shows windows, then stops working Aug 19, 2017 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.