I am trying to run VMware-Player-12.5.7-5813279.x86_64 on Ubuntu 17.04.

I installed it without problems but when I run it I get a message that gcc 7.1.0 is not found

error message


gcc --version

gives me 6.3.0

I tried following the guide here to install gcc-7 on Ubuntu 17.04. Then I tried following this guide in order to switch to an alternative compiler, but after doing it and typing

gcc --version

I get that I have gcc 7.0.1

Consequently, I still can't run VMware-Player.

I am running Kernel 4.12.8

I also tried the guide here, after doing all the previous steps, with and without reinstalling anything, whereby I changed (4,10,0) in the guide to (4,12,0), to no avail.

Can somebody help?


sudo update-alternatives --list gcc

and the output is



sudo update-alternatives --display gcc | column -t


gcc             -          manual          mode
link            best       version         is            /usr/bin/gcc-7
link            currently  points          to            /usr/bin/gcc-7
link            gcc        is              /usr/bin/gcc
slave           g++        is              /usr/bin/g++
/usr/bin/gcc-6  -          priority        60
slave           g++:       /usr/bin/g++-6
/usr/bin/gcc-7  -          priority        60
slave           g++:       /usr/bin/g++-7
  • Please run sudo update-alternatives --list gcc and lets see the output. – George Udosen Aug 19 '17 at 18:58
  • @George Added the required information as an edit to the post – ThunderBiggi Aug 19 '17 at 20:22
  • Please also run this sudo update-alternatives --display gcc | column -t and add the output. – George Udosen Aug 19 '17 at 20:27
  • @George Done with that – ThunderBiggi Aug 19 '17 at 20:30
  • All seems good from what I see, so don't know why VMWare isn't installing – George Udosen Aug 19 '17 at 20:33

I managed to get past the gcc problem (which is now at 7.2.0). I used the steps here, modifying them for gcc-7.2.0. (This is for 64bits system)

So, download the GCC 7 source and prerequisites from here

cd ~
wget http://gcc.parentingamerica.com/releases/gcc-7.2.0/gcc-7.2.0.tar.xz
tar xf gcc-7.2.0.tar.xz
cd gcc-7.2.0

We will install the compiler in /usr/local/gcc-7.2, as not to mess with the default compiler, as this might break your system.

cd ~
mkdir build && cd build
../gcc-7.2.0/configure -v --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu --prefix=/usr/local/gcc-7.2 --enable-checking=release --enable-languages=c,c++,fortran --disable-multilib --program-suffix=-7.2

Then we build the thing with

make -j 8

where we have specified that we want 8 threads to work on the job at the same time. The reason for this is that I have 4 cores that are hyperthreaded (they can each process 2 threads at the same time). Adjust this according to your setup. This step takes a lot of time - took me around 30 minutes on a decent laptop. Once the above is done, install the compiler

sudo make install

Now we jsut have to tell our system to use this compiler. I didn't do what is advised in the guide that I have linked at the top, instead I followed this in order to set up an alternative compiler by doing

sudo update-alternatives --install /usr/bin/gcc gcc /usr/local/gcc-7.2.0/bin/gcc-7.2 50 --slave /usr/bin/g++ g++ /usr/local/gcc-7.2.0/bin/g++-7.2

And then selecting the alternative compiler, using

sudo update-alternatives --config gcc
| improve this answer | |
  • Has anyone tried this? ..I also need to install gcc-7.2 on my Ubuntu 14.04 in order to run VM Workstation Player. – johann_ka Sep 25 '17 at 4:23
  • I tried it and it works – ThunderBiggi Sep 25 '17 at 7:41
  • Worked for me. Minor correction to the second from last command, for those that are copy and pasting - remove the minor version number: sudo update-alternatives --install /usr/bin/gcc gcc /usr/local/gcc-7.2/bin/gcc-7.2 50 --slave /usr/bin/g++ g++ /usr/local/gcc-7.2/bin/g++-7.2 – dmcquiggin Oct 21 '17 at 19:40

This process (including dmcquiggin's change in the comments) worked for me for:

Version: VMWare Workstation 14 Pro (14.1.1 build-7528167) OS: Ubuntu 16.04.4 LTS Kernel: x86_64 Linux 4.15.0-041500-generic

With one caveat: I had to edit the download_prerequisites script to point it to another mirror as ftp://gcc.gnu.org/pub/gcc/infrastructure/ was down.

I used the mirror: http://gcc.skazkaforyou.com/infrastructure/ instead.

This is one of the official GCC mirrors.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.