1

I want to make the mouse speed faster. But the "Mouse and Touchpanel" settings window seems to do nothing (does it actually do anything? it shows completely wrong values and changes there change nothing)

What can I do to increase mouse speed?

Questions like this are asked and answered (e.g.) here

They advice to use

xset

or

xinput

further, using dconf doesn't work, because there is no such entry on my system.

xset does not change anything on my system. xinput does not offer any option for mouse speed/sensitivity on my system:

Device Enabled (139):   1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Accel Speed (276): -1.000000
libinput Accel Speed Default (277): 0.000000
libinput Accel Profiles Available (278):    1, 1
libinput Accel Profile Enabled (279):   1, 0
libinput Accel Profile Enabled Default (280):   1, 0
libinput Natural Scrolling Enabled (281):   0
libinput Natural Scrolling Enabled Default (282):   0
libinput Send Events Modes Available (260): 1, 0
libinput Send Events Mode Enabled (261):    0, 0
libinput Send Events Mode Enabled Default (262):    0, 0
libinput Left Handed Enabled (283): 0
libinput Left Handed Enabled Default (284): 0
libinput Scroll Methods Available (285):    0, 0, 1
libinput Scroll Method Enabled (286):   0, 0, 0
libinput Scroll Method Enabled Default (287):   0, 0, 0
libinput Button Scrolling Button (288): 2
libinput Button Scrolling Button Default (289): 274
libinput Middle Emulation Enabled (290):    0
libinput Middle Emulation Enabled Default (291):    0
Device Node (263):  "/dev/input/event6"
Device Product ID (264):    1203, 12556
libinput Drag Lock Buttons (292):   <no items>
libinput Horizonal Scroll Enabled (265):    1

So is there any way to increase the mouse speed? ... why is the mouse support so bad? oO

0

From your xinput output, you may want to consider changing Accel Speed to something > than the current value of -1.000000. The largest value for this parameter is 1.0, which is maximum acceleration, and will likely give you the increased mouse speed that you're seeking.

As an example, I'm using -.1 for my acceleration value.

To temporarily (for the session) set a new value, use the following command: sudo xinput set-prop <n> 276 -.1, where <n> is the property value of the mouse/touchpad determined by running xinput list (it appears that you've already done this, but the device is not listed in your output).

To permanently set this value, you'll need to edit the libinput.conf file located in /usr/share/X11/xorg.conf.d. Option details/syntax are available on this site (e.g., AccelSpeed).

  • The acceleration has this value on purpose. I strongly dislike mouse acceleration, as it makes the mouse move with different speeds at different times. – DarkTrick Aug 20 '17 at 23:20
  • 1
    I have "Accel Speed" set to 1.0, but it is anyway too slow and I can't set higher value, unfortunately, xset and xinput don't work at all – 4xy Apr 12 '18 at 18:02
  • I have two monitors with high resolution, but my mouse speed is too slow. I try to set Accel Speed to a value > 1 but I get Error of failed request: BadValue (integer parameter out of range for operation). < 0 doesn't get it work. – Ninh Pham Aug 1 '18 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.