0

I installed ISPconfig on my Ubuntu Desktop 16.04. When I rebooted, it booted into command line instead of gui and the system is read only so i cannot make changes or uninstall what I did. The hostname at the top also does not say my server name, it says a subdomain name that was set during the ISPconfig installation.

Thanks for taking time to help me with this.

I have tried before and the output I get from mount -o rw,remount / is mount: / not mounted or bad option

The output from fsck -f / is fsck from util-linux 2.27.1 e2fsck 1.42.13 (17-May-2015) Pass 1: Checking inodes, blocks, and sizes Pass 2: Checking directory structure Pass 3: Checking directory connectivity Pass 4: Checking reference counts Pass 5: Checking group summary information /dev/sda6: 332167/53886976 files (0.7% non-contiguous), 41586480/215535872

  • How did you install ISPconfig... from a .deb file, or something else? – heynnema Aug 18 '17 at 21:02
  • I ran an automated script found at howtoforge.com/tutorial/ispconfig-automated-install-script – GWillieStyle Aug 21 '17 at 0:18
  • I looked at that web page, and it clearly says that ISPconfig is for Ubuntu Servers... NOT Ubuntu Desktop! – heynnema Aug 21 '17 at 1:44
  • I am using my ubuntu desktop as a server. I usually just SSH into it but I installed Desktop to have the option to use the GUI and remote into a windows VM I have on the server. ISPconfig has turned my server into a read only system making it unusable. Which shouldn't be the case no matter what version of ubuntu it is. – GWillieStyle Aug 22 '17 at 2:26
0

To uninstall ISPconfig...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access

At the # prompt, type:

fsck -f / # to check the file system

repeat the fsck command if there were errors

mount -o rw,remount /dev/sda6 # to remount the disk r/w

/root/ispconfig/uninstall # to uninstall ISPconfig

reboot # to reboot the system

  • Thanks for the help. I had used mount -o rw,remount / in the past but i finally tried mount -o rw,remount /dev/sda6 / and it worked. – GWillieStyle Aug 23 '17 at 22:52
  • I now have to do mount -o rw,remount /dev/sda6 / overtime I boot. Do you know how to fix this? – GWillieStyle Aug 23 '17 at 23:33
  • Since you have a highly modified system... that is... a server config with a GUI desktop... I don't know how to help you here, as I don't really know the server part. You could start a new question for this current problem and see if somebody else can help. I'm sorry. – heynnema Aug 24 '17 at 0:01

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.