This question already has an answer here:

When I boot the computer, it briefly prompts to press DELETE to go into UEFI BIOS, then goes to the GRUB menu prompting which option of Ubuntu to boot with: generic or advanced. There is no Windows option anywhere in this menu. When I installed Ubuntu, I used a live-USB, following the official Ubuntu tutorials on installing Ubuntu to a USB (with Rufus and the iso file), and the installation guide, without deviating from the tutorial instructions. After booting with the USB, I successfully installed Ubuntu with the OEM option. (Booting with the "Install Ubuntu" option didn't work, I got a ubi-partman failed with exit code 151 error. Windows 10 v. 1511 was installed originally on an OEM software disc, where I since upgraded it to v. 1703.) During the installation I opted to install Ubuntu alongside Windows 10, then got this pop-up here.

The original partitions are still visibile here, showing that filesystem partition 1 (which Windows 10 is installed on) is reserved, bootable, but not NTFS mounted, partition 5 has the parition type "Linux", mounted at the filesystem root, and partition 6 has the partition type "Linux swap" and has contents "Swap (version 1) — Active".

I tried to follow Karel's answer on the linked question, but it seems to be lacking in details. I booted from the live USB, pressed e to go to command line, pressed tab to see the available commands, and saw no option for sudo. I pressed esc and in GRUB selected "Try Ubuntu without installing", and got a list of errors. Similarly, I tried selecting check disk for errors, with the first line being:

initramfs unpacking failed: LZMA data is corrupt.

Unfortunately I can't post more images due to my limited privileges.

I wanted to export the HTML file from the Brave browser on Windows to the Brave browser on Linux.

marked as duplicate by αғsнιη, Eric Carvalho, Organic Marble, David Foerster, user364819 Aug 21 '17 at 9:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @Zanna, for the boot repair answer in that link, how do I navigate to the live-USB from the terminal? – James Ray Aug 18 '17 at 6:49
  • I'm not sure what is meant by: "From the Ubuntu live USB, open the terminal". Restart the computer with the live USB and somehow open BASH from Grub? – James Ray Aug 18 '17 at 7:02
  • OK, thanks @karel, unambiguity is definitely helpful for instructions! – James Ray Aug 18 '17 at 9:01
  • @karel, unfortunately I am unable to select the option: "Repair Windows boot files" as it is greyed out. – James Ray Aug 18 '17 at 9:42
  • 1
    All good now, after changing the OS that boots by default to Windows (via the sda5 menu), I rebooted, and Ubuntu was at the top of the grub list (so actually will still boot by default), and I could tap down to Windows at the bottom of the list, and boot to Windows without issues. If I knew how to close this post I would. – James Ray Aug 18 '17 at 9:57

From Ubuntu open the terminal (e.g. with CTRL+ALT+T) and type or copy and paste (you may need to enter one command at a time since it prompts for a password):

sudo add-apt-repository ppa:yannubuntu/boot-repair  
sudo apt-get update  
sudo apt-get install -y boot-repair
sudo boot-repair  

Open the Boot Repair application, try the recommended repair first, then restart. I think doing this fixed the issue for me. If Windows still doesn't show in the Grub menu, boot into Ubuntu and open Boot Repair again, click advanced options, and in the second tab from the left (Grub location), select the dropdown menu for the option: OS to boot by default and select Windows (via the sda5 menu). (You can always change it back again later. I thought that changing this default boot option to Windows fixed the issue, however after checking this option again, it is set to boot by Ubuntu by default, so I may have not applied the changes.)

Restart the computer. In the grub menu, to boot by Windows, quickly tap down to go to Windows and press enter, making sure you cancel the 5 s timeout by tapping down, before the 5 s timeout automatically selects the option highlighted. Ubuntu is still at the top of the list, but there are three other options. The original options were only Ubuntu generic and Ubuntu advanced (with sub-options in advanced). Now, the new options are two memory tests, and Windows at the bottom of the menu.

Make sure you update the Linux system time as described here, otherwise the system time on Windows will be the UTC time (which is the hardware time set by Linux), rather than the local time. I found that the simplest solution was to update the Linux system time.

Open a terminal and execute the following command:

timedatectl set-local-rtc 1

Alternatively, update the Windows system time to the UTC time, as also described in the linked post.

Not the answer you're looking for? Browse other questions tagged or ask your own question.