3

I tried to install virtualbox for the first time on my ubuntu 16.04 machine following the instructions here. When tried to run from terminal with command virtualbox it gave me the error below:

VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen("/usr/lib/virtualbox/VBoxRT.so",) failed: <NULL>

VirtualBox: Tip! It may help to reinstall VirtualBox.

and when tried to run by searching virtualbox an icon appeared in sidebar and after some seconds disappeared.

I tried downloading the official deb file form the virtualbox website and install with sudo apt install ./virtual... but the same error happened.

I also completely removed virtualbox with --purge option and its user and group every time I tried to reinstall.

The interesting part is that it was easy to install the Virtualbox on an ubuntu 16.04 hosted by another virtualbox on a windows machine.

Any answer or comment would be appreciated.

Edit (Solved)
Thanks to Charles the problem solved by changing the owner and group of /usr and /usr/lib to root by the following commands:

sudo chown root:root /usr
sudo chown root:root /usr/lib

My problem was that I only changed the owner by sudo chown root /usr.

  • There is a similar error on the virtualbox forums - can you enter the command ls -ld /usr && ls -ld /usr/lib and append the results to your question? – Charles Green Aug 17 '17 at 20:06
  • Thanks for the link and the command. Problem solved. @CharlesGreen – szamani20 Aug 18 '17 at 5:49
  • @CharlesGreen Please add an answer providing your successful solution for the OP to accept, so this can be closed. – dessert Aug 18 '17 at 6:17
  • So you previously changed the owners of /usr and /usr/lib to someone who is not root? Remember not to do that again. – edwinksl Aug 18 '17 at 12:54
  • @edwinksl I can't imagine that it's very good practice, but it is possible that some installation routine given sudo access may have made the change. – Charles Green Aug 18 '17 at 12:57
3

As mentioned at VirtualBox Forums the owner and group of /usr and / or /usr/lib may have been incorrectly set.

Check the two directories with ls -ld /usr && ls -ld /usr/lib - both the user and group of the directories should be root. If not, they can be set with:

sudo chown root:root /usr /usr/lib
  • does not work for me – Tobias K Nov 19 '18 at 14:12
  • @TobiasK It didn't work for me either. I had to remove and reinstall virtualbox to fix this. – Anthony Dec 18 '18 at 19:04
0

I'd like to add that also directories permissions matter. I've got the same error even with the correct owner root:root (after chown): the problem was the access level (777):

ls -ld /usr/lib
drwxrwxrwx 182 root root 20480 dic 19 15:50 /usr/lib
sudo chmod 755 /usr/lib
ls -ld /usr/lib
drwxr-xr-x 182 root root 20480 dic 19 15:50 /usr/lib

Once changed to 755 virtualbox started without problems. Just as a reference in case anyone have the same issue.

Surely Virtualbox users could benefit of a more specific error message (and how/when owner and permissions of the directories were changed is still something to clarify)

  • does not woek for me – Tobias K Nov 19 '18 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.