1

Is my first question here because Ubuntu never gives me any problems but yesterday I did a very stupid thing.

Any time LibreOffice starts, it says that is impossible to recover a file on a mounted disk. I thought that it must be because of a permissions issue and that the best solution was to give LibreOffice superuser permissions.

I tried from a terminal

sudo libreoffice

Since I did that it is impossible to open LibreOffice in the usual way. I can only start the app as superuser from a terminal using sudo.

When using the usual ways (with my normal user) I get a Fatal Error:

Can't start the application, can't complete user install.

(In Spanish)

Libreoffice start after using "sudo libreoffice"

How can I restore the application or reinstall the user configuration?

I am using Ubuntu 15.04 in Spanish language, but I suppose the same would apply to other distros when LibreOffice is started using sudo.

0

Close libreoffice, then run:

sudo chown -R $USER: ~/.config/libreoffice/

it should fix all necessary ownership problems.

If it didn't work, then try moving the broken configuration files:

sudo mv ~/.config/libreoffice{,-rm}
  • hmm, dont works... – Marco Antonio Achury Palma Aug 17 '17 at 17:16
  • Dont't worked, now even dont shown the error message :-s Appear that libreoffice create more config files somewhere else, I have also installed and unistalled libreoffice wilthout success. – Marco Antonio Achury Palma Aug 17 '17 at 22:43
  • I'll let you know if I came up with an alternative ;) – Ravexina Aug 18 '17 at 4:07
0

thanks for your help.

The problem was solved this way:

delete ~/.config/libreoffice and then:

sudo dpkg-reconfigure libreoffice

I lost some personal config, libreoffice become as a new install but now works well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.