4

I have been using Sublime (build 3126) on my Ubuntu machine and it's been working well. I went away on vacation for a week and since I came back, it's been extremely laggy--even just typing in my text file has a significant delay.

My project is quite large with many files, but no more than before I left. Opening a clean window outside of my project lags the same anyway.

I have already tried disabling all third party plugins, uninstalling and reinstalling, and uninstalling and trying Sublime Text 2. Nothing has helped.

This is my first Ubuntu machine so outside of performing all the updates and emptying the trash (which I've done) I'm not sure what other things are good to try. Nonetheless, the computer works fine elsewhere. EDIT: My terminal application seems a little sluggish, but I probably wouldn't have even noticed without the Sublime issue.

Here's the output from top:

enter image description here

Sublime console output:

DPI scale: 1
startup, version: 3126 linux x64 channel: stable
executable: /opt/sublime_text/sublime_text
working dir: /
packages path: /home/pnic/.config/sublime-text-3/Packages
state path: /home/pnic/.config/sublime-text-3/Local
zip path: /opt/sublime_text/Packages
zip path: /home/pnic/.config/sublime-text-3/Installed Packages
ignored_packages: ["Vintage"]
generating syntax summary
generating meta info summary
pre session restore time: 0.63143
startup time: 0.686569
first paint time: 0.695814
first paint time: 0.698497
reloading plugin Default.auto_indent_tag
reloading plugin Default.block
reloading plugin Default.comment
reloading plugin Default.convert_syntax
reloading plugin Default.copy_path
reloading plugin Default.delete_word
reloading plugin Default.detect_indentation
reloading plugin Default.duplicate_line
reloading plugin Default.echo
reloading plugin Default.exec
reloading plugin Default.fold
reloading plugin Default.font
reloading plugin Default.goto_line
reloading plugin Default.history_list
reloading plugin Default.indentation
reloading plugin Default.install_package_control
reloading plugin Default.kill_ring
reloading plugin Default.mark
reloading plugin Default.new_templates
reloading plugin Default.open_context_url
reloading plugin Default.open_in_browser
reloading plugin Default.pane
reloading plugin Default.paragraph
reloading plugin Default.paste_from_history
reloading plugin Default.profile
reloading plugin Default.quick_panel
reloading plugin Default.run_syntax_tests
reloading plugin Default.save_on_focus_lost
reloading plugin Default.scroll
reloading plugin Default.set_unsaved_view_name
reloading plugin Default.settings
reloading plugin Default.show_scope_name
reloading plugin Default.side_bar
reloading plugin Default.sort
reloading plugin Default.swap_line
reloading plugin Default.switch_file
reloading plugin Default.symbol
reloading plugin Default.transform
reloading plugin Default.transpose
reloading plugin Default.trim_trailing_white_space
reloading plugin CSS.css_completions
reloading plugin Diff.diff
reloading plugin HTML.encode_html_entities
reloading plugin HTML.html_completions
plugins loaded
  • 1
    This is a strange problem. Is there anything else that could have changed? I would consider running 'top -u' in a terminal to see if anything is eating your cpu cycles... – Goran Aug 18 '17 at 4:05
  • Nope--CPU is 93% free. – thumbtackthief Aug 21 '17 at 15:21
  • Your configuration is stored in `~/.config/sublime-text-3. Please move or rename this folder and start sublime without your custom settings. Does it lag the same then? – dessert Aug 21 '17 at 18:18
  • @dessert Yes, no help. :( – thumbtackthief Aug 21 '17 at 19:12
3

Sublime Text is probably indexing the files in your project. You can ignore folders, e.g. third party libraries, to speed up the indexing.

You can add this to your User Settings:

"folder_exclude_patterns": [
  "bower_components/**",
  "node_modules/**",
  "vendor/**"
]

However, this will also hide the folders from the sidebar. You can instead use binary_file_patterns to exclude the files from being indexed, while still being displayed in your sidebar.

"binary_file_patterns": [
  "bower_components/**",
  "node_modules/**",
  "vendor/**"
]

The last resort is to disable indexing altogether, but this will disable some Sublime Text most useful features.

"index_files": false
| improve this answer | |
  • Unfortunately this didn't help--for future seekers, though, did you mean "index_files": false? – thumbtackthief Aug 18 '17 at 14:13
  • Should have been false indeed. Also, check the status messages in the ST console, these might be helpful to find the cause. – idleberg Aug 18 '17 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.