0

I've followed this guide to install CUDA on Ubuntu 16.04 LTS. It requires me to boot into text mode. However it appears really hard to get Ubuntu to actually start in text mode as needed to move on with CUDA installation. I've tried following various guides to this including:

Booting into text mode in 16.04
https://linoxide.com/ubuntu-how-to/5-steps-start-ubuntu-text-mode/
I also tried GRUB_CMDLINE_LINUX="3" instead of "text" and GRUB_CMDLINE_LINUX_DEFAULT="quiet splash 3"

No matter what it keeps booting into the standard graphics "windows" like interface. Any help would be much appreciated.

  • No it's not a duplicate of that one. I just needed to boot into text mode at the time of asking. I wasn't at the point of actually installing CUDA. Sorry if my question wasn't detailed enough. I edited above accordingly. – Greforb Aug 18 '17 at 6:50
  • Your self-answer proves your point. – karel Aug 18 '17 at 6:57
1

OK, after spending another day searching the web I finally found the solution here. It appears that on top of

  • editing the GRUB (setting GRUB_CMDLINE_LINUX="text" and GRUB_CMDLINE_LINUX_DEFAULT="quiet" and enabling/uncommenting GRUB_TERMINAL=console, remember to finally update the GRUB by executing sudo update-grub)
  • setting the default target to multi-user.target (sudo systemctl set-default multi-user.target, I actually don't know if this step is necessary, but I did it and it worked after next step),

I needed to disable lightdm (sudo systemctl disable lightdm.service). After these steps ubuntu finally fired up in text mode and I successfully installed CUDA and nVIDIA graphics drivers.

Note that I'm now having the problem that lightdm does not start again after reboot, even after enabling it again (sudo systemctl enable lightdm.service). I haven't solved this yet, and will post new question if I don't find the answer somewhere.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.