1

I believe an apt update changed something and now rtorrent is failing to load.

rtorrent: error while loading shared libraries: libcrypto.so.1.0.2: cannot open shared object file: No such file or directory

Any suggestions?

This is on Ubuntu 16.04.

Running sudo find / -name "libcrypto.so.*" shows to locations of different versions of the so.

  • /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1
  • /lib/x86_64-linux-gnu/libcrypto.so.1.0.0
  • Did you try to install it with sudo apt install libcrypto++9v5? What's the output of this? – dessert Aug 17 '17 at 7:19
  • @dessert That package wasn't installed but It's still complaining :( – Malachi Aug 17 '17 at 7:30
  • 1
    If this doesn't help, try sudo apt install -f, and if that also doesn't help, sudo apt --reinstall install rtorrent. – dessert Aug 17 '17 at 7:33
  • And you may sudo apt purge libcrypto++9v5 if it's not needed. ;) – dessert Aug 17 '17 at 7:34
  • Installing rtorrent from apt fixed it. I was running a build from source version before which I guess is why when the dependencies changed it all broke. :/ – Malachi Aug 17 '17 at 8:06
2
sudo apt --reinstall install rtorrent

fixed it in this case. OP was runnig a version manually built from source before, but when libcrypto.so.1.0.2 was not available on the system any more due to an update it refused to work. Installing rtorrent from the package sources solves the problem in such a case. For 16.04 this has no downsides as package sources hold version 0.9.6, which is the most recent one at the moment. However, if there is a non-package-system version installed it's a good idea to remove this first before installing the package version, to avoid collisions and keep the system clean.

  • Software not managed by apt cannot be removed by apt. – user692175 Aug 17 '17 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.