I recently put together a new server running Ubuntu Server 11.10 and it's all working great except for one little detail. Whenever I run "sudo reboot" everything works fine until I get to the grub page, where it auto-selects ubuntu and then only displays a black screen. There is nothing showing on the screen, and I can't access the server with a keyboard. Neither can I access it over SSH.

If I hold the power button down and force the computer to shut down, it will boot in to Ubuntu normally the next time. This only happens the time I run "sudo reboot", and not the following I start it.

As I said, I can't spawn a terminal on the server, not even if I connect a keyboard. It's like it's frozen. I thought maybe somebody here could help me, because I've been trying to solve this for days.

In case this is helpful, I've got a RAID5 running on the server, but I can't imagine it to be the root of the problem.

EDIT: I forgot to write, but I also have a 64GB Crucial M4 as my system disk, where Ubuntu is installed. The raid is just for storage.

These are the server specifications:

  • Motherboard: Asus P8H67-M B3
  • CPU: Intel Core i3 2120 3,3GHz
  • GPU: Asus GeForce ENGT520
  • Memory: Corsair XMS3 DDR3 PC10666/1333MHz CL9 2x4GB
  • HDD: 3x Seagate Barracuda Green ST2000DL003 64MB 2TB

Thanks in advance!


Maybe something wrong with the GPU feeding data. See this answer: Black screen after updating Ubuntu 11.04 and Mobility HD 4250 which leads to the X/Troubleshooting/Blank screen Wiki, containing useful information to solve these issues.

What I did to solve of GPU feeding data failure was editing the grub.cfg file by dropping the next in a terminal:

sudo gedit /boot/grub/grub.cfg

As mentioned on "Workaround B" in the Wiki page. Then remove the "splash" word on each grub's entry. And the problem was solved.

You can either edit grub.cfg file via Live Session with a CD/DVD or USB bootable. And there are some other workarounds that may help you.

I hope you find a solution soon.

Good luck!

| improve this answer | |
  • I went to check the file, but there is not a single instance of "splash" inside it. Thanks for your answer though! – Jonathan Jan 12 '12 at 21:53

It sounds like something is trying to clean up when you reboot but is failing - when you hard-power-off, the shutdown script doesn't get run and so doesn't have a chance to mess things up. You should be able to check the scripts in /etc/init.d and see if any of them fail when you stop them, especially with services that you've installed that aren't in the base ubuntu install. You can manually stop services using:

service <whatever> stop

And look at the output on screen or in the logfiles in /var/log. Don't forget to re-start them when you're done testing.

Based on your question, I would check the filesystem/mount scripts first and see if any of them are throwing errors.

[Edit: rewrote this answer due to my previous one referring to a very old upstart config]

| improve this answer | |
  • I tried opening the file you told me to check, but the it's empty. There is no content in it. Could it be that it's located somewhere else? Also, if it helps; I've got XMBC installed to autostart on boot. – Jonathan Jan 11 '12 at 20:10
  • I'll try to shut down all services that I installed and then reboot. Hopefully I can re-activate them all one by one and find the problematic one, if that is the problem. – Jonathan Jan 12 '12 at 21:55
  • Now I have another issue, my system seems to freeze, but I can't find anything in the log files about it. I have to force shut the computer down in order for it to function. I see on my mac that the connection was closed, and XBMC is completely frozen, I can't even switch terminal. – Jonathan Jan 12 '12 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.