0

When installing Ubuntu on my Acer TravelMate Spin B1 B118-RN-P7XQ the installation stops/freezes when installing GRUB2. When I then reboot the notebook (so the installation is not complete) I get to the GRUB2-command-line, where I can boot Ubuntu manually. However, every attempt to fix GRUB freezes the notebook.

This is the case with Ubuntu 16.04 LTS with and without getting updates at installation time and Ubuntu 17.04 without getting updates.
Only when installing Ubuntu 17.04 WITH updates during installation time, the installation still freezes, but I can then boot right into Ubuntu. (However I doubt the installation is very usable/stable because of the incomplete installation...)

One possible workaround is to first install Ubuntu 17.04 with updates, then installing another Ubuntu with ubiquity -b (no bootloader), in which case the installation successfully completes.

Things I have tried:

  • using another distribution: Ubuntu GNOME, Linux Mint, Antergos (with GRUB2); always the same
  • calling Acer customer support: they switched the motherboard (?) and basically told me that they don't support Ubuntu, Ubuntu is not compatible (yet), and I should switch to Windows 10
  • installing Antergos with systemd-boot instead of GRUB2, installing Windows 10; both work fine

This notebook comes with Endless OS, a strange Linux distribution, preinstalled (I can also successfully reinstall it). It also uses GRUB2 (Acer apparently has made it work on that distro).

Did I make any mistake?
If not, can I help somewhere to fix this problem, e.g. by providing (hardware-)information and/or testing? I'm not using the notebook actively, there is no data on it, so it might come handy.

Update 1: sudo parted -l after installing Ubuntu 17.04 with updates:

Model: ATA Micron_110_MTFD (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size   File system  Name                  Flags
 1      1049kB  538MB  537MB  fat32        EFI System Partition  boot, esp
 2      538MB   256GB  256GB  ext4

Update 2: https://paste2.org/9175MVMI
Also, boot-repair get's stuck at reinstalling GRUB...

Update 3:
diff, left is Ubuntum right is EndlessOS: https://www.diffchecker.com/d1QXLt5a

Update 4:
Error still occurs with Ubuntu 17.10.1 (though workaround exists).

14
  • Is this an UEFI install? Acer Spin 5 Ubuntu 17.04 Needs Acer password & trust askubuntu.com/questions/908854/… Or is it an older BIOS install? If UEFI you need gpt partitioning and then the ESP - efi sytem partition for grub to install. Post this: sudo parted -l – oldfred Aug 16 '17 at 19:48
  • @oldfred It is UEFI. But I have disabled SecureBoot to eliminate this potential issue (Acer-support said it is okay). GPT partitioning is done automatically by the script, but yes, it includes the ESP-EFI-partition. – Mat2095 Aug 16 '17 at 19:53
  • @oldfred At which point should I run sudo parted -l? (before/after installation, 16.04/17.04, with/without updates, or after second installation for the workaround) – Mat2095 Aug 16 '17 at 19:55
  • Whatever is most current. It was more to confirm whether MBR or gpt(UEFI). Are you installing Ubuntu in UEFI boot mode?, Grub will error in BIOS mode on gpt drive as it needs a bios_grub for BIOS boot. But you want UEFI boot. Have you updated UEFI from Acer? Acer Spin 5 Ubuntu 17.04 Needs Acer password & trust askubuntu.com/questions/908854/… & Acer Trust Settings - details, some now report that then secure boot has to be on to set trust: ubuntuforums.org/showthread.php?t=2358003 – oldfred Aug 16 '17 at 19:58
  • @oldfred I've added the result from parted. Yes, I'm installing in UEFI boot mode. Yes, UEFI is the latest version (1.05). I have Acer password set. I have tried adding ubuntu grub as trusted, that didn't help with the problem on older versions. On the latest version booting is not a problem anyway, only the installation is freezing. – Mat2095 Aug 16 '17 at 21:19
1

If just installing the grub package proves to be the issue and you can remove the drive to put it in another computer, then do just that and install Ubuntu there. Make yourself familiar with working around missing UEFI NVRAM entries, there are several ways to approach this, and you should have a bootable system when you mount the drive again. If the storage is just one (or more) soldered chips to the mainboard then you would need another drive to install on another computer, boot up a live disk on the target computer configure the partition table, copy all the contents of root and the EFI system partition with sudo rsync -av and configure /etc/fstab for the correct UUIDs. Some people would prefer some disk dump/clone but I prefer this one. With UEFI you wouldn't even need to call grub for modifications to the MBR if the proves to be the part where it crashes.

That would solve your problem by thinking outside the box. ;) Investigating the problem further would be a good idea. Endless OS is based on Debian if I recall correctly, it's not strange, it's actually very nice and has some advantages (no bad or stuck updates, steam via flatpak). It's worth a second look, don't write it off just because it's made for non-tech savvy people.

3
  • It's a M.2-SSD but I don't have another system with a M.2-Slot. I'll try installint on another drive and update here when I'm done. I don't think Endless OS is bad either, but I definitely don't see myself as its target-audience. – Mat2095 Aug 18 '17 at 22:20
  • This worked quite well, everything seems to run fine. Ubuntu is doing some hardware-checks during installation, do I have to expect problems, because I'm using it on different hardware now? – Mat2095 Sep 3 '17 at 18:55
  • @Mat2095 That is unlikely. The Linux kernel has almost all drivers except proprietary ones (that can be installed through the restricted driver menu) and I have yet to come across hardware that requires special configuration or additional packages to be detected during installation (there are special Ubuntu images for licensed hardware like Dell's Sputnik, though these customizations should be upstream and available for everyone in later releases). It should be fine. – LiveWireBT Sep 3 '17 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.