4

I installed the 11.10 VirtualBox image from http://virtualboxes.org/images/ubuntu/ on my Windows 8 Developer Preview x64 machine running VirtualBox 4.1.8.

I've previously installed it manually from the .iso.

Unfortunately all the symbol keys are incorrectly mapped on the VirtualBox image version.

So I apt-get install dkms virtualbox-ose-guest-utils, and restarted. That didn't make a difference.

So I updated all software through Update Manager, to no avail.

After restarting, I installed the Guest Addons through the outer VirtualBox options, then installed it within the guest. Successful install (updated by 0.0.2 versions), but no change in key bindings even after reboot.

How do I fix my keybindings?

FYI: Seamless mode only sort-of works.

  • This is an even bigger bummer if you've chosen to encrypt the HD during install and then can't enter correct decrypt pw at launch. No way to change the settings then. Just have to recreate the VM. – tir38 Nov 24 '16 at 3:28
  • @tir38 - You might have some luck with a shared clipboard – A T Nov 25 '16 at 13:36
6
+100

Have you checked your keyboard layout for the system?

Maybe the keyboard layout is not the correct one in Ubuntu and you need to select a new keyboard layout that corresponding to what you use.

You can do so by clicking the user cog wheel > System Settings > Layout Settings, test the layout that fits better and re-test the keys on the system.

enter image description here


I have downloaded the Virtualbox image and started it, the default selected keyboard layout is Italian, which can be correct if you are Italian but that can also be not true. If you are not Italian or using a normal Italian keyboard then you need to change your keyboard's layout.

Also the image is using the Italian updates mirror, you might want to change that in your software sources to your own or a closer country to you.

For that please have a look at this post

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.