0

I've been trying to install Ubuntu on my Dell XPS 15 9560. But on boot I'm getting kernel errors and more when trying too boot from the installation USB. I will link a picture for better understanding.

enter image description here

I've tried to boot Ubuntu, Elementary os and Redhat. Tried to use different "Bootable USB" creator tools. Also removed an old grub boot installation from the EFI partition.

marked as duplicate by Byte Commander, karel, Eric Carvalho, Pilot6, user364819 Aug 21 '17 at 9:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which Ubuntu release is it and what are your hardware specs, most importantly what CPU model do you have? Is it an Intel Skylake (6th generation) or newer? – Byte Commander Aug 16 '17 at 9:53
  • Ubuntu 16.04 Desktop. And I have a Dell XPS 15 9560 with Nvidia gpu and Intel i7-7700HQ CPU – Murillio4 Aug 16 '17 at 10:02
  • 2
    Yours is a Kabylake (7th generation), but the issue is the same that the 16.04 kernel (at least 16.04.0 uses 4.4 as GA kernel) doesn't support the integrated graphics of these new CPUs yet. You could try either installing 16.04.3 which should come with the 4.10 HWE kernel already, or 17.04 which also uses 4.10. Otherwise boot your 16.04 with nomodeset and update the kernel there. – Byte Commander Aug 16 '17 at 10:21
  • This is an Nvidia issue. – Pilot6 Aug 20 '17 at 8:48

Browse other questions tagged or ask your own question.