0

This question already has an answer here:

I'm trying to mount my secondary disk "2TB" in "User1" home directory. I used the "Disks" tool unmounted the 2TB disk >> Mount Options > then changed the Mount Point to /home/User1/Desktop/2TB. When I try to mount the disk again I get this error message

Error mounting system-managed device /dev/sda1: Command-Line 'mount "/home/User1/Desktop/2TB" existed with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program or other error. In some cases useful info is found in syslog - try dmseg | tail or so. (udisks-error-quark, 0)

What is the meaning of the error message and how to fix mount my 2TB disk to User1 Desktop?

odoo@odoo-server:~$ dmseg | tail
No command 'dmseg' found, did you mean:
 Command 'mmseg' from package 'sunpinyin-utils' (main)
 Command 'dmesg' from package 'util-linux' (main)
dmseg: command not found
odoo@odoo-server:~$ dmesg | tail
[111847.580077] audit: type=1326 audit(1502853701.271:37): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=17834 comm="vsftpd" exe="/usr/sbin/vsftpd" sig=31 arch=c000003e syscall=37 compat=0 ip=0x7f19b84de6d7 code=0x0
[112028.927039] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[112156.908954] audit: type=1326 audit(1502854010.591:38): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=19225 comm="vsftpd" exe="/usr/sbin/vsftpd" sig=31 arch=c000003e syscall=37 compat=0 ip=0x7f19b84de6d7 code=0x0
[112231.855116] EXT4-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[112416.979618] audit: type=1326 audit(1502854270.659:39): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=19781 comm="vsftpd" exe="/usr/sbin/vsftpd" sig=31 arch=c000003e syscall=37 compat=0 ip=0x7f19b84de6d7 code=0x0
[112571.897055] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[112571.982229] systemd-hostnamed[21350]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[112699.479816] audit: type=1326 audit(1502854553.151:40): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=21426 comm="vsftpd" exe="/usr/sbin/vsftpd" sig=31 arch=c000003e syscall=37 compat=0 ip=0x7f19b84de6d7 code=0x0
[112849.342441] audit: type=1326 audit(1502854703.011:41): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=21573 comm="vsftpd" exe="/usr/sbin/vsftpd" sig=31 arch=c000003e syscall=37 compat=0 ip=0x7f19b84de6d7 code=0x0
[113019.536448] EXT4-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
odoo@odoo-server:~$

odoo@odoo-server:~$ sudo parted -l
Model: ATA WDC WD20PURX-64P (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name  Flags
 1      17.4kB  2000GB  2000GB  ext4         2TB


Model: ATA Crucial_CT275MX3 (scsi)
Disk /dev/sdb: 275GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system     Name  Flags
 1      1049kB  538MB  537MB   fat32                 boot
 2      538MB   258GB  257GB   ext4
 3      258GB   275GB  17.1GB  linux-swap(v1)



odoo@odoo-server:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=c69948a3-9b7d-4fd7-b66c-9dd885c92f08 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=DF63-A313  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sda3 during installation
UUID=db6be66c-5106-40b5-a030-f456f2c635ca none            swap    sw              0       0
#/dev/disk/by-uuid/ab37b9d4-9510-4480-aa84-d5f598aa1d92 /mnt/ab37b9d4-9510-4480-aa84-d5f598aa1d92 auto default 0 0
/dev/disk/by-uuid/12C066590FB763E6 /home/cam1/Recording auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0

marked as duplicate by muru, Community Aug 16 '17 at 5:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you try dmesg | tail after the error was shown? – muru Aug 16 '17 at 3:39
  • Are you sure it is sda, not sdb or something other than sda which normally is first drive. And did you create folder for User1, it would be $USER if you want the default first user, otherwise you are trying to create or use User1. see echo $USER And then in /Desktop do you have /2TB? Post this: sudo parted -l & cat /etc/fstab above to preserve formatting. – oldfred Aug 16 '17 at 3:43
  • @muru, I added the results of the "dmseg | tail" – Ramez Dous Aug 16 '17 at 4:01
  • @oldfred .. I added the result to "dmesg | tail". Then I changed the mounting options on "Disks" to automatic then i executed the other two command "parted -l & cat /etc/fstab" – Ramez Dous Aug 16 '17 at 4:07
  • Seems to be this bug. – muru Aug 16 '17 at 4:08
0

Simple fix:

Change "x-gvfs-show" to "comment=x-gvfs-show" in the /etc/fstb

Source: Unrecognized mount option "x-gvfs-show" or missing value

Not the answer you're looking for? Browse other questions tagged or ask your own question.