0

I just switched from Windows to Kubuntu 16.04 and would like to set my keyboard to polytonic Greek to type every combination of diacritic necessary in a comfortable way.

I set up Greek (polytonic) as another keyboard layout and a switch with a shortcut to change between German and Greek.

Somehow the way I used to type stacked diacritics in Windows doesn´t work out any more. The greek letters are displayed, but of the abundant varieties of diacritics possible only four (acute, gravis, circumflex and iota subscriptum) are typed, and none of them stackable. (On a German QWERTZ-Keyboard these are "ö" + "a", "ä" + "a", "ü" + "a" and "+" + "a", respectively; this increases confusion, as some instructions like "hit [any key]" are difficult for me to figure out as I don´t know which physical keyboard setting the instructor has at hand).

How to type Greek characters with a breathing and accent is related, and I studied the answer presented, but I fail to find the language support mentioned there in Kubuntu, and to change the input to XIM.

What I would like is two things:

  1. The setting of character-combinations I have grown used to in the past five years, and which is somewhat explained in the article: http://homepage.ruhr-uni-bochum.de/Thomas.Ihnken/Zeichentabelle.htm (it´s in German, but the combinations are somewhat clear). I´m quite quick typing them, and if there is an easy way to set them up in this way this would save me a lot of time. Is there some kind of idiot-guide at hand to help me set it up?
  2. Somehow since I have switched to Kubuntu some of my editors don´t display the combinations. If I hit the keys for alpha+circumflex, in this stack-exchange-editor only ~α is displayed, also in sublime-text-editor. In LibreOffice, however, it works. Is there a global solution?
  • There are several Greek keyboard layouts to choose from: Greek, Greek (extended), Greek (polytonic), Greek (without dead keys), Greek (simplified). – user692175 Aug 16 '17 at 1:02
  • In order to set XIM, to follow the solution in the related answer, you can start the Input Method Configuration tool directly by opening a terminal window and running the command im-config. – Gunnar Hjalmarsson Aug 16 '17 at 1:14
  • @Gunnar Hjalmarsson: Thank you for the clarification. I have now set xim and set my right ctrl to work as control key, and it now works for certain environments, such as LibreOffice Writer and this editor. But in sublime-text the compose-key is somewhat not activated as I don΄t get the desired character. Has this got something to do with Kubuntus global settings, or has it probably got something to do with sublime-text? – Kubo Aug 17 '17 at 14:41
  • @Gunnar Hjalmarsson: I also have two follow-up-questions: (1) Is there a resource to look up the names of certain keys in the compose-files? For example I don΄t know key is meant with <dead_horn>, and simply looking it up in a search-machine hasn΄t yielded any results. – Kubo Aug 17 '17 at 14:44
  • (2) You suggested creating a separate compose-file for certain characters; is it possible just to add some combinations to the existing one instead? I΄d somehow like to have them all in one place. – Kubo Aug 17 '17 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.