1

I'm trying to mount a USB drive plugged on my Technicolor router.

I have the following line in my /etc/fstab:

//192.168.1.1/usbdisk /media/public cifs guest,vers=3.0 0 0

After trying resolving the issue with diffrerent instructions found from the net I have tried specifying different versions, vers=2.0, vers=2.1, but none of these have resolved the issue.

If I test with smbclient, I get the following:

sudo mount.cifs //192.168.1.1/usbdisk /media/public -o username=myuser,vers=2.0
Password for myuser@//192.168.1.1/usbdisk:  *********
mount error(112): Host is down

Same happens with no user specified, and also with various vers= definitions.

I'm running Ubuntu 15.10. Any ideas?

  • I am having the exact same issue. It was working for months and now went down. No updates on either side. – Bill Garrison Aug 25 '17 at 17:00
  • Hi, since I updated from Ubuntu fromn 17.04 to 17.10 I have the same issue. Smbclient still works, also trhough gvfs I can access the share – Gerhard Stein Oct 25 '17 at 6:26
5

You can disable the entry in /etc/fstab and issue the following command

mount -t cifs //192.168.1.1/usbdisk /media/public -o guest,vers=3.0

and at the same time play around with different options (behind -o). If you need feedback from you system, you might open a second terminal windows and type journalctl -fb to watch how the kernel reacts on your options given.

I explain all this because your real issue might be different with cifs than it was in my case.

I had the problem that the device offering SMB wants ver=1.0. While Ubuntu 17.04 didn't have any problems with the version (auto), the 17.10 and its kernel demands to indicate the number, as my Kernel logs shows:

Okt 25 09:06:08 gespc kernel: No dialect specified on mount. Default has changed to a more secure dialect, SMB3 (vers=3.0), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 specify vers=1.0 on mount. For somewhat newer servers such as Windows 7 try vers=2.1.

My Good luck!

  • My problem was the version, I needed to set vers=1.0. journalctl -fb helped to understand that. – frenesim Feb 5 '18 at 9:29
1

YES !

Had this problems for months too, solved with adding vers=1.0 in the options: //xxx.xxx.xxx.xxx/disk /media/foldername cifs rw,credentials=/etc/samba/credentials,uid=1000,gid=1000,file_mode=0660,dir_mode=0770,iocharset=utf8,vers=1.0 0 0

Thanks Gerhard!

GR

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.