3

Wifi is really flaky. Sometimes it disconnects. Sometimes it is fast for a few minutes, then it slows down again more and more till it says "no internet connection", then going fast after sometime.

Example of going flaky: When I try to load an HD image from google image search, that image will take ages to load and while it is being loaded, spotify and telegram will disconnect and other web browsing will be impossible, saying that there is no internet, when i am actually still connected to the wireless. Same for apt upgrade. Other devices like my Smartphone and my old x201 (16.04) don't have problems with the wifi.

  *-network
       description: Ethernet interface
       product: Ethernet Connection I218-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 04
       serial: 54:ee:75:0f:0b:89
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.6-4 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:47 memory:f0500000-f051ffff memory:f053e000-f053efff ioport:3080(size=32)
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 83
       serial: e8:2a:ea:08:51:83
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.10.0-32-generic firmware=17.459231.0 ip=192.168.1.109 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:46 memory:f0400000-f0401fff

What I have tried so far is this (obviously I adjusted the logical name), with no result. I am not an Ubuntu Expert, just a regular User. I hope someone has a suggestion on what else I can try! ubuntu was installed yesterday and update/upgrade have been done. Have a nice day.

edit: I ran the wireless info script, so here it is: https://pastebin.com/C3XWJSUC

edit2: Added some more accurate description of the wifi problem.

edit3: tried the live CD for ubuntu 17.04. Seemed fine, so I installed it. After installation, surfing with Firefox seemed good. I did apt update/upgrade and from there on it is flakey again like described above... Could it be some problem with ipv4/ipv6?

edit4: apparently it is a problem with my wifi. tried two different wifis and everything was fine. tried to restart my wifi but that didn't help.

edit5: Problem is solved for the moment. It was apparently caused by a WiFi repeater. Restarting the repeater helped a bit but turning it off made the problems go away. (No Problems for over a week now after turning off the repeater). So far so good. Question is still: How to deal with this issue when it is not an option to turn off the repeater? Maybe on a Public WiFi or a different place where there is a Repeater set up.

  • Thanks, I used the script and added the result to my post! – ivsterr Aug 15 '17 at 15:48
  • How slow is “really slow”? Did you try to measure the transmission speed? If so, how did you measure it and what was the result? What’s the output of ping -c10 192.168.1.1? The self-reported physical network speeds looks outstanding with over 800 Mb/s. – David Foerster Aug 15 '17 at 15:56
  • really slow is that if i am loading an image on google or doing 'apt upgrade', then spotify will disconnect, telegram won't be able to send any messages and I won't be able to browser the web. also using multiple tabs (just about 4) of regular browsing can make some of them suddenly say 'no internet' unless I wait for some time till it gets stable again. pinging the adress you gave me went alright: pastebin.com/UfP2ynyh – ivsterr Aug 15 '17 at 16:01
  • That’s no slow connection; that’s a flaky connection. The round trip times to the access point appear quite long. They should be almost always lower than 5 ms. Is the network flaky all the time or does it work well most of the time and then becomes flaky for a short period? – David Foerster Aug 15 '17 at 16:28
  • 1
    Hi David! Thanks a lot for your suggestions and help! I think the problem is not occurring anymore (no problems for more than a week so far). Apparently it was not the fault of my thinkpad but it is somehow caused by a WiFi repeater which is attached to this network. For some reason my phone and other devices are not affected but my thinkpad goes crazy. Restarting the repeater helped a bit, but just disconnecting the repeater did the trick for me. Noone is using the repeater for now. Any idea what to do if there is a situation like this again when a repeater is causing trouble? – ivsterr Sep 5 '17 at 19:32
7

Your problems are likely the result of power management being enabled and having aggressive TX disabled, to fix these issues enter these commands one line at a time

echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlopts.conf
sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot

Since there is more than one access point with the SSID you are connecting to, run

iwlist scan | egrep -i 'address|ssid|quality|chan'
in terminal and find the MAC address of the one with the highest quality and channel 10, then edit your Network Manager settings for this connection and choose the MAC address under the BSSID setting, then save and reboot

  • I don't think 11n_disable=8 is useful for 7260. It is for older ones. But I am not quite sure. – Pilot6 Aug 15 '17 at 15:49
  • Thanks for your quick response! I tried your commands and rebootet afterwards but it did not help. It is still very unstable and gets really slow when downloading something (sudo apt upgrade) or just loading a large image on google will just block every other service from using the network like spotify or telegram. however i just used the network diagnostics script and added it to my post. maybe that can shed some light. – ivsterr Aug 15 '17 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.