22

This had a bounty on it, it was not awarded as there was no good answer… ☹


I tried running apt-get update and got these warnings:

W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max                                                                            
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min                                                                            
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max                                                                           
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min                                                                                                                                                   
W: You may want to run apt-get update to correct these problems

As instructed, I tried apt-get update again and got the same warnings.

What can I do to fix those?

Full output follows:

    ; sudo apt-get update                                                          
    Hit http://security.ubuntu.com trusty-security InRelease                        
    Hit http://security.ubuntu.com trusty-security/main Sources                     
    Hit http://security.ubuntu.com trusty-security/restricted Sources               
    Hit http://security.ubuntu.com trusty-security/universe Sources                 
    Hit http://security.ubuntu.com trusty-security/multiverse Sources               
    Hit http://security.ubuntu.com trusty-security/main amd64 Packages              
    Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages        
    Hit http://security.ubuntu.com trusty-security/universe amd64 Packages          
    Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages        
    Hit http://security.ubuntu.com trusty-security/main i386 Packages               
    Hit http://security.ubuntu.com trusty-security/restricted i386 Packages         
    Hit http://security.ubuntu.com trusty-security/universe i386 Packages           
    Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages         
    Hit http://security.ubuntu.com trusty-security/main Translation-en              
    Hit http://security.ubuntu.com trusty-security/multiverse Translation-en        
    Hit http://security.ubuntu.com trusty-security/restricted Translation-en        
    Hit http://security.ubuntu.com trusty-security/universe Translation-en          
    Ign http://us.archive.ubuntu.com trusty InRelease                               
    Hit http://us.archive.ubuntu.com trusty-updates InRelease                       
    Hit http://us.archive.ubuntu.com trusty-backports InRelease                     
    Hit http://us.archive.ubuntu.com trusty Release.gpg                             
    Hit http://us.archive.ubuntu.com trusty-updates/main Sources                    
    Hit http://us.archive.ubuntu.com trusty-updates/restricted Sources              
    Hit http://us.archive.ubuntu.com trusty-updates/universe Sources                
    Hit http://us.archive.ubuntu.com trusty-updates/multiverse Sources              
    Hit http://us.archive.ubuntu.com trusty-updates/main amd64 Packages             
    Hit http://us.archive.ubuntu.com trusty-updates/restricted amd64 Packages       
    Hit http://us.archive.ubuntu.com trusty-updates/universe amd64 Packages         
    Hit http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages       
    Hit http://us.archive.ubuntu.com trusty-updates/main i386 Packages              
    Hit http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages        
    Hit http://us.archive.ubuntu.com trusty-updates/universe i386 Packages          
    Hit http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages        
    Hit http://us.archive.ubuntu.com trusty-updates/main Translation-en             
    Hit http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en       
    Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en       
    Hit http://us.archive.ubuntu.com trusty-updates/universe Translation-en         
    Hit http://us.archive.ubuntu.com trusty-backports/main Sources                  
    Hit http://us.archive.ubuntu.com trusty-backports/restricted Sources            
    Hit http://us.archive.ubuntu.com trusty-backports/universe Sources              
    Hit http://us.archive.ubuntu.com trusty-backports/multiverse Sources            
    Hit http://us.archive.ubuntu.com trusty-backports/main amd64 Packages           
    Hit http://us.archive.ubuntu.com trusty-backports/restricted amd64 Packages     
    Hit http://us.archive.ubuntu.com trusty-backports/universe amd64 Packages       
    Hit http://us.archive.ubuntu.com trusty-backports/multiverse amd64 Packages     
    Hit http://us.archive.ubuntu.com trusty-backports/main i386 Packages            
    Hit http://us.archive.ubuntu.com trusty-backports/restricted i386 Packages      
    Hit http://us.archive.ubuntu.com trusty-backports/universe i386 Packages        
    Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages      
    Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en           
    Hit http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en     
    Hit http://us.archive.ubuntu.com trusty-backports/restricted Translation-en     
    Hit http://us.archive.ubuntu.com trusty-backports/universe Translation-en       
    Hit http://us.archive.ubuntu.com trusty Release                                 
    Hit http://us.archive.ubuntu.com trusty/main Sources                            
    Hit http://us.archive.ubuntu.com trusty/restricted Sources                      
    Hit http://us.archive.ubuntu.com trusty/universe Sources                        
    Hit http://us.archive.ubuntu.com trusty/multiverse Sources                      
    Hit http://us.archive.ubuntu.com trusty/main amd64 Packages                     
    Hit http://us.archive.ubuntu.com trusty/restricted amd64 Packages               
    Hit http://us.archive.ubuntu.com trusty/universe amd64 Packages                 
    Hit http://us.archive.ubuntu.com trusty/multiverse amd64 Packages               
    Hit http://us.archive.ubuntu.com trusty/main i386 Packages                      
    Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages                
    Hit http://us.archive.ubuntu.com trusty/universe i386 Packages                  
    Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages                
    Hit http://us.archive.ubuntu.com trusty/main Translation-en_GB                  
    Hit http://us.archive.ubuntu.com trusty/main Translation-en                     
    Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en_GB            
    Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en               
    Hit http://us.archive.ubuntu.com trusty/restricted Translation-en_GB            
    Hit http://us.archive.ubuntu.com trusty/restricted Translation-en               
    Hit http://us.archive.ubuntu.com trusty/universe Translation-en_GB              
    Hit http://us.archive.ubuntu.com trusty/universe Translation-en                 
    Ign http://us.archive.ubuntu.com trusty/main Translation-en_GB.UTF-8            
    Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_GB.UTF-8      
    Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_GB.UTF-8      
    Ign http://us.archive.ubuntu.com trusty/universe Translation-en_GB.UTF-8      
    Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
    Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
    Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max                                                                               
    Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min                                                                               
    You may want to run apt-get update to correct these problems                    
    Reading package lists... Done                                                   
    W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max                                                                             
    W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min                                                                             
    W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max                                                                            
    W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min                                                                            
    W: You may want to run apt-get update to correct these problems 

I removed all external PPA, yet still get this error: therefore this is not a duplicate of Upgrade from 14.04 to 16.04 successful, but it failed actually?

More debugging based on comments:

; apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://apt.postgresql.org/pub/repos/apt/ precise-pgdg/main i386 Packages
     release o=apt.postgresql.org,a=precise-pgdg,n=precise-pgdg,l=PostgreSQL for Debian/Ubuntu repository,c=main
     origin apt.postgresql.org
 500 http://apt.postgresql.org/pub/repos/apt/ precise-pgdg/main amd64 Packages
     release o=apt.postgresql.org,a=precise-pgdg,n=precise-pgdg,l=PostgreSQL for Debian/Ubuntu repository,c=main
     origin apt.postgresql.org
 500 https://deb.nodesource.com/node_6.x/ trusty/main i386 Packages
     release o=Node Source,n=trusty,l=Node Source,c=main
     origin deb.nodesource.com
 500 https://deb.nodesource.com/node_6.x/ trusty/main amd64 Packages
     release o=Node Source,n=trusty,l=Node Source,c=main
     origin deb.nodesource.com
 500 http://ppa.launchpad.net/neovim-ppa/unstable/ubuntu/ trusty/main Translation-en
 500 http://ppa.launchpad.net/neovim-ppa/unstable/ubuntu/ trusty/main i386 Packages
     release v=14.04,o=LP-PPA-neovim-ppa-unstable,a=trusty,n=trusty,l=Neovim Unstable,c=main
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/neovim-ppa/unstable/ubuntu/ trusty/main amd64 Packages
     release v=14.04,o=LP-PPA-neovim-ppa-unstable,a=trusty,n=trusty,l=Neovim Unstable,c=main
     origin ppa.launchpad.net
 500 http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.6/main i386 Packages
     release n=llvm-toolchain-trusty-3.6,c=main
     origin llvm.org
 500 http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.6/main amd64 Packages
     release n=llvm-toolchain-trusty-3.6,c=main
     origin llvm.org
 500 http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.5/main i386 Packages
     release n=llvm-toolchain-trusty-3.5,c=main
     origin llvm.org
 500 http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.5/main amd64 Packages
     release n=llvm-toolchain-trusty-3.5,c=main
     origin llvm.org
 500 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main i386 Packages
     release n=llvm-toolchain-trusty,c=main
     origin llvm.org
 500 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main amd64 Packages
     release n=llvm-toolchain-trusty,c=main
     origin llvm.org
 500 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu/ precise/main Translation-en
 500 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu/ precise/main i386 Packages
     release v=12.04,o=LP-PPA-ubuntu-toolchain-r-test,a=precise,n=precise,l=Toolchain test builds,c=main
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu/ precise/main amd64 Packages
     release v=12.04,o=LP-PPA-ubuntu-toolchain-r-test,a=precise,n=precise,l=Toolchain test builds,c=main
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/certbot/certbot/ubuntu/ trusty/main Translation-en
 500 http://ppa.launchpad.net/certbot/certbot/ubuntu/ trusty/main i386 Packages
     release v=14.04,o=LP-PPA-certbot-certbot,a=trusty,n=trusty,l=Certbot PPA,c=main
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/certbot/certbot/ubuntu/ trusty/main amd64 Packages
     release v=14.04,o=LP-PPA-certbot-certbot,a=trusty,n=trusty,l=Certbot PPA,c=main
     origin ppa.launchpad.net
 500 http://security.ubuntu.com/ubuntu/ trusty-security/universe Translation-en
 500 http://security.ubuntu.com/ubuntu/ trusty-security/restricted Translation-en
 500 http://security.ubuntu.com/ubuntu/ trusty-security/multiverse Translation-en
 500 http://security.ubuntu.com/ubuntu/ trusty-security/main Translation-en
 500 http://security.ubuntu.com/ubuntu/ trusty-security/multiverse i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=multiverse
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/universe i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=universe
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/restricted i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=restricted
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/main i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=main
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/multiverse amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=multiverse
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=universe
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/restricted amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=restricted
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=main
     origin security.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/universe Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/restricted Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/multiverse Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/main Translation-en
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/multiverse i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=multiverse
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/universe i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=universe
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/restricted i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=restricted
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/main i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=main
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/multiverse amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=multiverse
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/universe amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=universe
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/restricted amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=restricted
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu/ trusty-backports/main amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-backports,n=trusty,l=Ubuntu,c=main
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/restricted Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/multiverse Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/multiverse i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=multiverse
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=universe
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/restricted i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=restricted
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=main
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/multiverse amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=multiverse
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=universe
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/restricted amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=restricted
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=main
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe Translation-en_GB
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/restricted Translation-en_GB
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/restricted Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse Translation-en_GB
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/main Translation-en_GB
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/main Translation-en
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse i386 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=multiverse
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=universe
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/restricted i386 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=restricted
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=main
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=multiverse
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=universe
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/restricted amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=restricted
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=main
     origin us.archive.ubuntu.com
Pinned packages:
; apt libapt-pkg\*
E: Invalid operation libapt-pkg*

Although, I suspect this might be more relevant:

; apt-cache policy python-cffi-backend-api-max python-cffi-backend-api-min
python-cffi-backend-api-max:
  Installed: (none)
  Candidate: (none)
  Version table:
python-cffi-backend-api-min:
  Installed: (none)
  Candidate: (none)
  Version table:
  • Please edit your question and add fully output of sudo apt update \\ Do you use any ppa ? – Ali Razmdideh Aug 15 '17 at 13:14
  • @ali76 Added the full output. Yes, I do use several ppa – Sardathrion - against SE abuse Aug 15 '17 at 13:54
  • What version of Ubuntu do you have? Your /etc/apt/sources.list seems to have repos for trusty, which is Ubuntu 14.04. Have you recently upgraded to a newer version? – Katu Aug 24 '17 at 11:53
  • @Katu Version is 14.04 as tagged. It was upgraded from 12.02 ages ago but not since then and the message is recent -- last two weeks. – Sardathrion - against SE abuse Aug 24 '17 at 12:34
  • Could you please edit your question to include the output of apt --version, apt-cache policy apt libapt-pkg\*? Thanks. – David Foerster Aug 29 '17 at 17:03
17
+25

This problem happens because your version of apt is "too old" and doesn't support packages that use versioned "Provides:".

You can check your apt version with

apt --version

"versioned provides" were added in apt 1.0.7, but Ubuntu 14.04 ships with apt 1.0.1.

See https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1662227 for more information.

The warning is harmless. If you really want to remove it, you can compile apt from sources to a version that supports versioned provides.

Warning!: Updating apt is potentially dangerous and can break the package manager.

If you choose to do it, follow these steps:

wget http://snapshot.debian.org/archive/debian/20150821T213547Z/pool/main/a/apt/apt_1.0.10.2.tar.xz
tar -xvf apt_1.0.10.2.tar.xz
cd apt-1.0.10.2
./configure
make
| improve this answer | |
  • So, the official way to get packages on Ubuntu 14.04 is broken with official 14.04 packages… Words fail me… – Sardathrion - against SE abuse Aug 24 '17 at 13:52
  • 1
    @Sardathrion the message is a warning, it's not broken. – Katu Aug 24 '17 at 14:03
  • 2
    -1 for the suggestion to update Apt. – fkraiem Aug 30 '17 at 0:00
  • 2
    @fkraiem I did not recommend to do this. I put it as the only way I know of removing the warning. I deliberatively said "compile" instead of "update" and I didn't include the sudo make install command at the end of the instructions. – Katu Aug 30 '17 at 7:41
  • 2
    Oh, clearly, I very much appreciate the time you took to write your answer and give you help. Nothing I say should be read as ungrateful. I am grateful for yourself and @fkraiem. – Sardathrion - against SE abuse Aug 31 '17 at 9:31
8

The real solution appears to track down the offending package and ask the PPA maintainer to fix it.

Since the issue happened because of certbot, I opened issue 6063 to tackle this. This comment asked the maintainer of the PPA to fix the problem.

As off Monday 23 October, this has been resolved. Make sure you do

sudo apt-get update
sudo apt-get upgrade

To get the changes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.