0

I'm using ubuntu 16.04, after an update, my touchpad stopped working properly.

Tap to click no longer works, the cursor speed is lower than it was, and scrolling got reversed.

I was using libinput before the update, I had a problem and someone suggested to install it to fix the problem, and it did, https://askubuntu.com/a/886098/625501

I tried opening the file /usr/share/X11/xorg.conf.d/90-libinput.conf put I think it's messed up or something, I'm not sure.

It looks like this

I tried sudo apt-get dist-upgrade and then sudo apt install xserver-xorg-input-libinput but it says it's up to date.

  • Why did you post text as a picture? – Pilot6 Aug 15 '17 at 9:06
2

Edit the /usr/share/X11/xorg.conf.d/90-libinput.conf

And add to the touchpad section after Driver "libinput"

Option "Tapping" "True"
Option "NaturalScrolling" "True"

Then log off and on. This will enable tapping and reverse scrolling.

  • Oh, that touchpad section, I Was looking at "Inputclass", thinking there was something wrong. It works now, thank you. BUt the cursor speed is still slow. – MichaelX Aug 15 '17 at 9:22
  • You can adjust cursor speed too, but I am leaving now. Meanwhile you can ask "how to adjust cursor speed in libinput" as a new question. If nobody answers, I will look at it tonight. – Pilot6 Aug 15 '17 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.