16

I have installed Google Earth Pro 7.3.0.3830 (64-bit) on my Ubuntu 16.04 LTS.

When I launch Google Earth Pro, map is shown in very small window. I have un-installed and re-installed but the problem is as it is.map is on left upper corner

1
13

Happened to me too, Its a graphics driver problem. It does not work on X.org nouveau graphics driver. More on it here. So you can uninstall the present version 7.3 and install 7.1 version from here.

6
  • 1
    The proper solution is to use the Nvidia proprietary drivers which is now a requirement. Downgrading is not recommended, regardless of what has been discussed in the link you posted. It's just procrastination. At one point, sooner than later, the old version will stop working. – user692175 Aug 16 '17 at 11:23
  • 1
    @Deepank Thank you. It has solved the issue for now. I have downgraded the version. – learner Aug 18 '17 at 3:15
  • MichaelBay, Thank you for your input, I have tried many things to update my graphics driver (RS690 Radeon X1200), but found that open source gallium is most reliable. – learner Aug 18 '17 at 3:17
  • I have a Macbook Air with some intel graphics card that had the same issue. Using 7.1.x made it work here, too. – cweiske Mar 15 '18 at 20:34
  • 1
    Interesting, I'm using the latest Intel Graphics drivers on 16.0.4 LTS and doesn't work; downgrading does. Graphics: Card: Intel Device 5916 bus-ID: 00:02.0; Display Server: X.Org 1.19.5 driver: intel; Resolution: 1920x1080@60.02hz, 1920x1080@60.00hz; GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2); GLX Version: 3.0 Mesa 18.0.1 - padoka PPA Direct Rendering: Yes – Andor Kiss May 30 '18 at 16:12
2

I have nouveau graphics driver and Google Earth Pro 7.3.2.5776 (64-bit) on Ubuntu 18.04 LTS.

You can try to use LIBGL_ALWAYS_SOFTWARE environment variable like this:

LIBGL_ALWAYS_SOFTWARE=1 /opt/google/earth/pro/googleearth

But this is just for a little look, because it is terribly slow.

1
  • Only thing that seems to work on my newish Intel GPU laptop.... and I can't tell it's sofware, it's pretty fast! – Dagelf Nov 18 '19 at 19:37
0

It got this problem on Ubuntu 18.04 LTS. I have a NVidia Graphic Card. I solved the issue like this.

To update the NVidia driver, execute in a terminal :

$ sudo ubuntu-drivers autoinstall

After, reboot. It worked for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.