1

This question already has an answer here:

Setup:

I've used Ubuntu Gnome 16.04 (UEFI installation) for some time now and had decided to upgrade to Gnome 17.04. After the upgrade some things were slightly messed up and I figured I might as well do a new clean installation of Ubuntu 17.04, since it usually doesn't take very long.

I created a USB boot stick using dd bs=4M status=progress if=ubuntu_gnome.iso of=/dev/sdc && sync.

I selected UEFI: (FAT) (3750MB) (my stick) in my boot order and got to the usual GRUB screen with the options to try Ubuntu, install Ubuntu, OEM install and check disc and as always clicked 'Install Ubuntu Gnome'. So far so good.

Problem:

However instead of the installation beginning the screen goes blank for a few seconds and then some gibberish appears and scrolls through the screen (like it would during something like apt get upgrade) for a few seconds then freezes.

gibberish on screen

Also:
everytime I've retried the whole process it added ubuntu(244198MB) to my boot list (after some time I had it in there 15 times, although the only present things should be the P6 and UEFI line - my SSD and the USB stick).

boot list

Things I've tried so far:

  1. simply let the computer sit for some time and see whether the problem solves itself on its own
  2. retry the whole process:
    • with the same stick and the old iso file
    • with the same stick after downloading a new iso file
    • with a different USB stick
  3. try both of the USB sticks on my laptop (this works, so I don't think they're the problem)
  4. double check whether my current Ubuntu installation uses UEFI (/sys/firmware/efi is present on my pc) and whether UEFI/BIOS settings are set to allow UEFI booting
  5. tried different USB ports on my pc (both USB 2 and 3)

All help is very much appreciated.

marked as duplicate by Pilot6, Charles Green, David Foerster, user364819, Anwar Aug 16 '17 at 14:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Thanks, your comment definitely nudged me in the right direction. Doing that stuff didn't enable me to do a UEFI install of Ubuntu immediately, but it allowed me to at least get some sort of output to work with by starting a BIOS/legacy install of Ubuntu (which oddly enough couldn't finish for some reason, the installer was disrupted by something). Well, I provided what I did after that in an answer below. Thanks – Simon Merkelbach Aug 15 '17 at 0:54
3

Alright I've solved the problem after looking at the link provided by MichaelBay. Apparently it was some kind of driver issue caused by my graphics card. Here's what I did:

  1. plug in the USB stick, select UEFI boot option in boot order of motherboard, boot into grub menu

  2. press e to edit boot settings, change quiet splash to nomodeset, boot with F10

  3. follow Ubuntu installer

  4. reboot, at reboot repeatedly press Shift to get into the grub menu, hover over 'Ubuntu' and again press e and change quiet splash to nomodeset and boot with F10

  5. in Ubuntu use sudo apt update and sudo apt upgrade

  6. repeat 4.

  7. launch 'Software & Updates' program, switch to tab 'Additional Drivers' and switch to the proprietary driver by NVIDIA

  8. reboot regularly

Now I can use my system normally.

Not the answer you're looking for? Browse other questions tagged or ask your own question.