2

I have an Intel NUC (NUC7i3BNH, i.e., using Intel High Definition Audio) running Ubuntu 16.04.3. Its intended use is for a media center. I'm unable to get HDMI audio working unless I allow the system to sit idle (5 minutes by default) long enough for the display to sleep. When the display is woken back up, HDMI audio works perfectly.

Pavucontrol has no effect on the issue. Full system suspend does not fix HDMI audio. I've tried multiple displays, same behavior with each.

Any ideas? Thanks!

  • That's weird. It seems HDMI was not projected 'to sleep'. Look this unsolved 2010-issue. Even on Windows we see complains about it! – Redbob Sep 21 '17 at 3:45
  • Same issue with Zotac CI549. – Jofre Oct 8 '17 at 9:56
  • Not an elegant solution but forcing a screen resolution as explained here askubuntu.com/questions/906266/… worked for me without having to wait for the go to Sleep. I hope I could automate it – Jofre Oct 8 '17 at 15:28
  • Maybe it's just a matter of selecting the right output? Check if my answer here fixes your problem: askubuntu.com/a/1024739/204815 – Lucio Paiva Apr 13 '18 at 17:30
0

UPDATE: This is fixed in kernel 4.14 and higher.

I have a NUC too (NUC7i5BNK) and this has been a pain.

You can force the display to sleep with /usr/bin/xset dpms force off command.

I included this line in the required startup script and fixed for my purposes (run as an emulation station, running RetroPie).

RetroPie usually launch stuff using a script called /opt/retropie/supplementary/runcommand/runcommand.sh, so I've edited this script.

If you want to use Kodi, edit Kodi startup script and before launch it include these 2 lines:

xset dpms force off
xset dpms force on

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.