4

long time reader, first question tho!

Since a new install of Ubuntu 16.04 LTS I have had a problem with Chrome and Chromium. After waking up my laptop from suspend, any attempt to open Chrome results in the Chrome window stalling and going greyscale. However, Chrome works fine after reboot and for any amount of time. It only has the problem after I have put the computer in suspend at least once.

As far as what I have tried to resolve the issue:

  • I have purged and reinstalled all instances of Chrome and Chromium. I am currently running Chromium 60.0.3112.78

  • I had no issues running Chrome on my last install of 16.04 LTS on this same computer

  • According to htop I have no issues with available RAM or other obvious resources

  • According to htop there are no other chrome processes running in the background (though I only know to look for google or chrome labeled processes)

  • I have tried disabling firewall (gufw) with no change

  • I have tried running the following variations on Chromium, including disabling extensions, incognito and running with temporary profile

I have run chromium-browser --verbose in an attempt to see what is happening. The text is too big to post here, but it doesn't appear to stop at the exact same spot every time, but around the same time (always ~3-5 seconds).

Also any attempt to run chromium-browser --enable-logging --v=1 has failed to produce a .log file (or at least anywhere I can find it is supposed to be).

Any thoughts? I can't seem to find this as a bug in any of the Chrome or Ubuntu list.

EDIT: 8/14/2017

I have finally found the output to the chrome_debug.log if anyone is interested. Not sure what the best way to post it is for this site.

  • Look in /var/log/syslog for error messages at time of freeze and report back to us please. – WinEunuuchs2Unix Aug 14 '17 at 15:00
  • Does this same behaviour happen in the Guest account (if you still have it), or any other account on the system? Show me free -h and swapon -s. Ping me at @heynnema. – heynnema Aug 14 '17 at 15:43
  • Alright, so I didn't see any error messages in /var/log/syslog, but did you have a specific log file in mind? I looked in kernel and firewall. – Tugg Aug 14 '17 at 16:25
  • @heynnema I have attached a screenshot of the files here. Also, I tried running under Guest account with the same result. – Tugg Aug 14 '17 at 16:31
  • If the chrome_debug.log file is large, use imgur.com. Does Chrome behave the same way as Chromium? Does Firefox work? – heynnema Aug 14 '17 at 16:39
1

After examining the logs and experimenting with the failure conditions, I found it was an issue of the x.org Nouveau video driver. Switching to the Nvidia driver resolved the issue.

I will continue looking for a solution to use the Nouveau driver instead, as it works much better for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.