0

I'm using Ubuntu Studio - Xenial Xerus 16.04.3 LTS and want to install Skype for Linux.

When I drag the Skype installer to the terminal I get the following message:

serafims@SATELLITE-C50-B:~$ '/home/serafims/Downloads/skypeforlinux-64.deb' 
/home/serafims/Downloads/skypeforlinux-64.deb: line 1: syntax error near unexpected token `newline'
/home/serafims/Downloads/skypeforlinux-64.deb: line 1: '!arch'

What can I do to resolve this issue?

2

It doesn't work like that. You need to write sudo dpkg -i before the file path. So write that in a terminal and then drag and drop the skype package.

1

In addition to spacelander's answer, who already pointed out the correct way on how to install the package, I aim to provide some explanation on why the error occurred:


The file you've downloaded is a package that contains the Skype software. You can see that it's a package because it has the .deb file extension.

Those files (the packages) are downloaded when you use package managers like APT (for example by executing sudo apt-get install <package-name>) or the Ubuntu Software Center and are installed by a tool called dpkg. It's also possible to download packages manually (just as you did). In this case only dpkg gets executed.

By dragging and dropping a file to the terminal window, the shell (the program running inside the terminal window handling all the commands you enter) tries to execute this file as if it was a runnable program. This can be helpful when you write shell scripts (which are little, runnable programs that execute commands just like you do when you type something in the terminal window).

In your case, dragging and dropping is however not helpful: The .deb file itself is not a runnable program but instead a collection of texts, binaries, images, sounds (every component of Skype) and therefore can't be run by the shell (it needs to be processed by dpkg). Nevertheless, the shell tries to execute the file like a script but fails.

This is the reason why you see the error message.

  • even though i didn't fully understand your answer, it cleared some things to me. but in that case, why didn't the software center launch the package when i tried to open the skype.deb with it? – Artūrs Serafims Vītiņš Aug 14 '17 at 11:58
  • Thank you for the feedback. You have tried to open the .deb with Ubuntu Software Center? That should have worked, but in the past I sometimes also had problems installing package files using it. By the way: What parts of my answer didn't you understand? I can try to improve my formulations, if that helps :) – TuringTux Aug 14 '17 at 12:18
  • the last too parts, but don't bother, it is beyond my comprehension at this time, and i don't want to get in to it :) – Artūrs Serafims Vītiņš Aug 15 '17 at 8:07
  • Ok, fine :) I nevertheless tried to improve it - maybe it can be helpful for a future visitor or you, if you once decide you want to get into it ;) – TuringTux Aug 15 '17 at 8:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.