4

This question already has an answer here:

I'm having quite the time getting my keyboard backlights to work on my ROG Zephyrus laptop. Some of the F# keys do not respond their dedicated function when holding the Fn key. Specifically the key combinations for adjusting keyboard backlight for my model FN+F3 to dim and FN+F4 to brighten.

Specifically, I have followed the many suggestions that were recommended from this link with no luck. I have edited the grub file as below and after updating grub I've done a reboot.

sudo vim /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
sudo update-grub
reboot

I've also tried:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi= acpi_backlight=intel
sudo update-grub
reboot

I've also defined several different options all at once. I've tried a few different combinations as well.

I'm not for sure which one of these it was but caused my computer to lock up on a reboot with two lines indicating a namespace error.

Another setting basically removed all functionality from the keyboard and I had to re image in order to retain basic keyboard functionality back.Some of these additional options that I'm referring to are in the link above but I'm including them below for completeness.

GRUB_CMDLINE_LINUX="acpi_osi=Linux"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi_Linux"

I've installed this "brightness-controller" that was suggested on another site but that doesn't resolve anything.

I'm running the 375.82 Nvidia graphics drivers without any issues.

The person in the link above that was asking the question listed some specs from their system using a certain command lshw -C display.

So I'm going to do the same if it will provide any useful information. For specs related to my computer you can refer to this link

  *-display               
   description: VGA compatible controller
   product: NVIDIA Corporation
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
   configuration: driver=nouveau latency=0
   resources: irq:127 memory:db000000-dbffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:c0000-dffff
Quick update 08/16/17

I emailed the driver support team from Asus and they informed me that they are using the Atk drivers to control the keyboard brightness.

So I did some searching around and came across an article here that mentions to run the following command.

echo 3 > /sys/class/leds/asus\:\:kbd_backlight/brightness;exit

However, when I run the command I'm denied permission. So I added sudo like so and it still failed... Results

So my first question is why I can't execute this command and if I'm doing something wrong what the correct command would be.

From here I looked at what the contents of that location were:

Image1

I then tried a few different commands hoping for a different outcome but the command I tried still failed even with sudo:

Image2

What am I doing wrong here? Can someone give me some commands to try out on this directory to see if I can change the brightness.

marked as duplicate by David Foerster, Eric Carvalho, Yaron, dessert, Zanna Oct 4 '17 at 9:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Hi. Your post is bumped to the front page every time you edit it. So adding new information or things you've tried is good. But please don't make trivial edits just to bump. Reputation is not awarded by moderators, it is received by votes on your posts. See the help center for more information. – Seth Aug 17 '17 at 17:06
  • Also, don't go begging for rep either. (We will frown on you if you do that too much - as such I removed your message and inquiry to moderators, because it's superfluous and does not add anything other than a "I want rep" beging.) – Thomas Ward Sep 28 '17 at 20:10
  • Could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what's too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Sep 28 '17 at 20:15
  • if the echo 3 command works when run correctly, you should use sysfsutils to set it permanently - see No `rc.local` in 16.10, so how can I add a command to set brightness on boot? – Zanna Oct 4 '17 at 9:04
4

I can confirm the Zephyrus keyword isn't working for 17.04

I had the same problem, and I was able to solve it, but I'm using Gentoo with 4.12-8 vanilla sources.

My solution was adding blacklisting asus-nb-wmi, for that, you need the following text inside /etc/modprobe.d/blacklist.conf file

blacklist asus-nb-wmi

I hope it works! The problem seems to be related because asus-nb-wmi adds one fake (or wrong detected) keyboard device, and hid_asus also adds other device, so desktops seems to be using the first one which is wrong. blacklisting will avoid the bad one and keep the other correctly.

This solution will add suspend, airplane mode, keyboard lights, screen lights, screen keys and volume. That doesn't fix the numeric keyboard.

Regards

  • I added that entry into blacklist.conf file and then did a restart. The lights did not come on. I tried toying around with Fn+F3 and Fn+F4 but nothing happened. I have several entries in the blacklist.conf file so is there something I should uncomment as the result of adding in your fix? Is there anything else I'm missing? Would you mind sharing that file or listing what entries you have in there? Thank you for responding! – shanedora Aug 26 '17 at 22:16
  • 1
    I'm sorry my delay, it seems you need to be using at least kernel 4.12, following this Linus branch of Linux github.com/torvalds/linux/commit/… . If you can found some way to use 4.12 or later on Ubuntu, please try doing what I said. – WalterCool Aug 30 '17 at 9:00
  • Your comment above fixed my issue which was updating my kernel to 4.12 – shanedora Oct 12 '17 at 2:50
0

I was facing this issue today. I think it's just a permission issue : sudo is not exactly the same as being root on the entire line. To avoid this, the best is to become truly root :

sudo su
echo 3 > /sys/class/leds/asus\:\:kbd_backlight/brightness

Note that you can also choose 1 and 2 as values, and bind those commands to keyboard shortcuts.

  • You have the same misconception as OP; although you found a work-around. See the question that I linked in the comments for more info. – David Foerster Sep 28 '17 at 20:17
  • Looks quite like the same solution. Just added a clarification for the range of sudo. – Renon Lift Sep 28 '17 at 21:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.