I have 2 machines both running Ubuntu 16.04.3 with the Unity desktop environment.

I enabled Desktop Sharing, and disabled Require Encryption. I am able to connect to and use desktop on Machine-A with TightVNC. Machine-B fails with this message:

...target machine actively refused it.

netstat shows vino-server listening on Machine-A. Not listening on Machine-B.

I can enable vino-server by running /usr/lib/vino/vino-server and then successfully connect. I need to do this locally. Command does not work over remote SSH session.

The configuration is the same on both machines. Why does vino-server not start on one of them?

Added /usr/lib/vino/vino-server to Startup Applications, vino-server is now starting when I login locally. I tried this before without success. Possibly I entered the path wrong previously.

However, I would like vino-server to auto start without the need of me logging in locally first.

Rebooted and connected via SSH, ran /usr/lib/vino/vino-server and got: Failed to connect to Mir: Failed to connect to server socket: No such file or directory Unable to init server: Could not connect: Connection refused Cannot open display:

Added /usr/lib/vino/vino-server to rc.local, no change.

  • 1
    Does it make any difference if you turn off the firewall with gufw? – heynnema Aug 13 '17 at 23:13
  • 1
    I have always had to add vino-server into the autostart list manually. – Organic Marble Aug 14 '17 at 2:51
  • @heynnema - Firewall isn't the problem. vino-server does not start. Once I manually start vino-server I can connect. – Ookla Aug 14 '17 at 13:13
  • @Organic Marble - I tried adding /usr/lib/vino/vino-server to autostart, but no difference. Still needed to start vino-server manually. – Ookla Aug 14 '17 at 13:14
  • In terminal, before manually starting vino-server, do systemctl status and look for any services that failed to start. – heynnema Aug 14 '17 at 14:43

Could never get vino-server to start on boot, only when I login locally. Installed x11vnc and added systemd script. Able to VNC from Windows 10 using TightVNC to the Ubuntu box after a reboot and no local login. x11vnc presents the Unity desktop, so no need to install any alternative desktop environment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.