1

I've got running an Ubuntu desktop and a home server (Ubuntu server). Both are 16.04.3 LTS xenial. The kernels are different. Ubuntu server got the newest kernel. By decrypting some stuff on the server what I before encrypted on my desktop I got an error. I read that this is caused by different openssl versions. And so it is. The desktop got the 1.1.0f version. The server has 1.0.2g. Why ubuntu install different openssl versions either the systems got the newest upgrades? How can I keep them up on the newest version? I thought APT keep them up to date.

  • On both machines, run apt-cache policy openssl to find out where you got the different versions from. Note that you made a typo, it's 1.0.1f which is lower than 1.0.2g. All releases from Xenial (16.04) upwards have 1.0.2g. – popey Aug 13 '17 at 16:22
  • "I thought APT keep them up to date" - why did you think that? Automatically installed SYSTEM CHANGES violate the Linux Way (My System, My Choice). You have to run the "Software Updater" yourself. – waltinator Aug 13 '17 at 16:24
  • @popey Thank you for your hint! It was no typo. I ran apt-cache policy openssl and yes the desktop package comes from an other ppa which is using a different php version. I wonder about that there is also an other openssl version. So, is there a way to exclude openssl from updating by the other ppa? @waltinator You are right. I meant when using APT ... – thilos Aug 13 '17 at 22:31
  • I downgraded explained in (askubuntu.com/questions/340530/…). I don't know if it is the best solution. – thilos Aug 13 '17 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.