2

This is a problem I've been struggling with for the past couple months after upgrading to ubuntu gnome 17.04.

The system freezes randomly, the keyboard stops working, the screen freezes and there will be a second mouse pointer that can sometimes still move around, if music is playing, it continues normally for a little while then it starts repeating the last second indefinitely. Sometimes some weird pixels appear on the screen like on this image:

image

At first I suspected the problem might be related to gnome since it appeared to happen only when I interacted with the file system, but recently it's been occuring quite randomly so now I suspect it's related to the graphics driver.

I have a Dell XPS L502x, the technical specs can be found here: https://www.newegg.com/Product/Product.aspx?Item=N82E16834200301

This is the output for some commands that were requested on a similar post:

$ ls -alt /var/crash
total 52296
drwxrwsrwt  2 root  whoopsie     4096 Aug 12 14:42 .
-rwxrwxrwx  1 root  whoopsie        0 Aug 12 14:40 .lock
-rw-r-----  1 root  whoopsie   821234 Aug 11 09:31    _sbin_plymouthd.0.crash
-rw-r-----  1 ayoub whoopsie 52718583 Aug  9 00:39 _usr_bin_gnome-   shell.1000.crash
drwxr-xr-x 14 root  root         4096 Apr 12 04:18 ..

and:

$ dpkg -l intel-microcode
dpkg-query: no packages found matching intel-microcode

and:

$ free -h   
              total        used        free      shared  buff/cache   available
Mem:           5.7G        2.4G        2.0G         43M        1.3G        3.0G
Swap:          9.3G          0B        9.3G

and:

$ swapon
NAME      TYPE      SIZE USED PRIO
/dev/sda5 partition 9.3G   0B   -1

and:

$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=ac127e9c-c40e-4e9d-98ef-f653c06d73b6 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=6ac5ceab-16c3-4d0e-a5ca-753af7670c36 none            swap    sw              0       0

UUID=3098-9FFC /data vfat uid=1000,gid=1000,umask=0022,sync,auto,rw 0 0

and:

$ sudo blkid
/dev/sda3: UUID="300aaa08-9126-4cdd-9c65-b146abf4b42f" TYPE="ext4" PARTUUID="f1a89952-03"
/dev/sda4: UUID="3098-9FFC" TYPE="vfat" PARTUUID="f1a89952-04"
/dev/sda5: UUID="6ac5ceab-16c3-4d0e-a5ca-753af7670c36" TYPE="swap" PARTUUID="f1a89952-05"
/dev/sda6: UUID="ac127e9c-c40e-4e9d-98ef-f653c06d73b6" TYPE="ext4" PARTUUID="f1a89952-06"

and:

$ ls -al /
total 8268
drwxr-xr-x  26 root  root      4096 Aug 13 11:42 .
drwxr-xr-x  26 root  root      4096 Aug 13 11:42 ..
drwxr-xr-x   2 root  root      4096 Jun 28 19:19 bin
drwxr-xr-x   3 root  root      4096 Aug 12 09:56 boot
drwxrwxr-x   2 root  root      4096 May 12 22:10 cdrom
-rw-------   1 root  root  12574720 Jul  3 22:51 core
drwxr-xr-x   8 ayoub ayoub    32768 Jan  1  1970 data
drwxr-xr-x  20 root  root      4360 Aug 13 12:01 dev
drwxr-xr-x 133 root  root     12288 Aug 13 12:01 etc
drwxr-xr-x   4 root  root      4096 May 13 16:33 home
lrwxrwxrwx   1 root  root        33 Aug 13 11:42 initrd.img -> boot/initrd.img-4.10.0-32-generic
lrwxrwxrwx   1 root  root        33 Aug 12 09:58 initrd.img.old -> boot/initrd.img-4.10.0-32-generic
drwxr-xr-x  22 root  root      4096 Jun 20 18:11 lib
drwxr-xr-x   2 root  root      4096 Jun 20 18:11 lib32
drwxr-xr-x   2 root  root      4096 Jun 20 18:11 lib64
drwx------   2 root  root     16384 May 12 22:05 lost+found
drwxr-xr-x   4 root  root      4096 Jun 27 15:30 media
drwxr-xr-x   2 root  root      4096 Apr 12 04:06 mnt
drwxr-xr-x   7 root  root      4096 Jun 19 21:28 opt
dr-xr-xr-x 306 root  root         0 Aug 13 12:01 proc
drwx------   8 root  root      4096 Aug 12 11:36 root
drwxr-xr-x  29 root  root       900 Aug 13 12:07 run
drwxr-xr-x   2 root  root     12288 Jun 28 19:19 sbin
drwxr-xr-x   2 root  root      4096 Apr  6 09:32 snap
drwxr-xr-x   2 root  root      4096 Apr 12 04:06 srv
dr-xr-xr-x  13 root  root         0 Aug 13 12:01 sys
drwxrwxrwt  15 root  root     61440 Aug 13 12:06 tmp
drwxr-xr-x  11 root  root      4096 May 12 23:56 usr
drwxr-xr-x  14 root  root      4096 Apr 12 04:18 var
lrwxrwxrwx   1 root  root        30 Aug 12 09:58 vmlinuz -> boot/vmlinuz-4.10.0-32-generic
lrwxrwxrwx   1 root  root        30 Aug  4 09:49 vmlinuz.old -> boot/vmlinuz-4.10.0-30-generic

and:

$ nvidia-smi
Sun Aug 13 12:26:38 2017       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 375.66                 Driver Version: 375.66                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GT 525M     Off  | 0000:01:00.0     N/A |                  N/A |
| N/A   69C    P0    N/A /  N/A |    261MiB /   964MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0                  Not Supported                                         |
+-----------------------------------------------------------------------------+

I also tried the fix mentioned here relating to intel c-states but the problem remains: How to set intel_idle.max_cstate=1

  • What's on sda3? – heynnema Aug 13 '17 at 15:41
  • It contains my home partition before the upgrade from 16.04. – Ayoub E. Aug 13 '17 at 15:50
  • So where is your /home now? Where are your files? And why don't I see a mount for /home in your /etc/fstab? Something just doesn't sound right. – heynnema Aug 13 '17 at 15:53
  • My /home doesn't have a separate partition in this setup – Ayoub E. Aug 13 '17 at 15:55
  • @AyoubE. Same problem I was having with my Nvidia drivers see this link – Shayan Mar 24 '18 at 22:12
0

Two problems... there may be more wrong... but this is a start...

Your /etc/fstab file is incorrect. Edit it with:

In terminal...

gksudo gedit /etc/fstab

Change:

UUID=3098-9FFC /data vfat uid=1000,gid=1000,umask=0022,sync,auto,rw 0 0

To:

# /boot/efi was on /dev/sda4 during installation
UUID=3098-9FFC /boot/efi vfat defaults 0 1

Also, install intel-microcode:

sudo apt-get update
sudo apt-get install intel-microcode
reboot

Lastly, go to http://memtest86.org and download the free memory test and run at least one full pass to test your memory.

  • I'm thinking this was just a mistake, but in case it isn't, why do I have to change /data to /boot/efi? – Ayoub E. Aug 13 '17 at 15:42
  • The entire line is incorrect. That vfat partition should be mounted on /boot/efi. Did you manually enter/change that line? – heynnema Aug 13 '17 at 15:44
  • Yes, that's a custom partition I have mounted on /data following some tutorial a while back, I'm pretty sure it has nothing to do with the error I'm facing since I've had it setup this way for more than a year now. – Ayoub E. Aug 13 '17 at 15:46
  • I'm curious as to why it should be mounted on /boot/efi though? – Ayoub E. Aug 13 '17 at 15:47
  • Well, the tutorial was wrong to have you edit/change /etc/fstab. You can either take my advice to fix it... or not... – heynnema Aug 13 '17 at 15:47
0

As I suspected, the cause seems to be the nvidia driver, after uninstalling it the problem no longer occurs.

EDIT: I installed the 381.22 driver and it's working as expected for my GPU

EDIT 2: Unfortunately, the problem is still here with the 381.22 driver.

  • So what driver are you running on now? Is it the xserver-xorg-video-nvidia package? I have the same problem, but haven't found a solution so far(have to run under Windows which doesn't have any issues). I'll fiddle around with drivers again, but I'm not very optimistic. – Nikola Ivanov Nikolov Aug 15 '17 at 9:51
  • I haven't installed any other driver, but I just checked and it looks like it defaulted back to nouveau – Ayoub E. Aug 15 '17 at 13:04
  • I see. For me it doesn't even let me login with the nouveau driver, so I had to SSH and uninstall and install the nvidia driver. Not sure if I installed a different driver now or something, but so far it's been ok(and GPU is not running nearly as hot as before). – Nikola Ivanov Nikolov Aug 16 '17 at 11:58
  • Let us know what driver was installed if the problem no longer happens by running the nvidia-smi command. – Ayoub E. Aug 19 '17 at 10:56
  • I'm using the 375.66 driver and things are smooth for 5+ days now. No more freezing - hybernation and waking up are fine(with some visual artefacts after waking up, but they go away when I move the area in question). This is with a GeForce 840M. – Nikola Ivanov Nikolov Aug 20 '17 at 21:20
0

XPS L50* integrated GPU which doesn't stand a long term use. It was kind of an experimental GPU and Nvidia can't do much to stabilise it through drivers as the hardware problem shall still persist.

The problem is not just with the Nvidia driver but the binding of the GPU and the CPU itself. The thermal paste has degraded over the years. And most of the time the freezes and reboots are caused when the GPU heats up.

If Nvidia acknowledged the flaw they would have to replace the entire XPS L50* series. Integrated GPUs like this have cost us the entire system being unstable.

The only way to get away with this would be to blacklist the Nvidia drivers.

0

Well, I had the same problem: My PC was freezing randomly. I tried Ubuntu 16, 17 and 18.04 and everything was the same. I tried several drivers and didn't get a solution. I tried several solutions that I found in the forums and got bad and harmful results.

My Nvidia graphic Card works fine with Windows, but it doesn work with Ubuntu 17 neither beta 18.04, so the problems are the drivers in Ubuntu. I had removed Nvidia graphic Card and now I using the integrated Intel graphics processor (-Intel® HD Graphics 530 (Skylake GT2) -) and the problem was gone.

Well, for me this is the real solution while Ubuntu and partners find the solution of the problem with this graphics card

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.