2

This is likely to be a MacBook specific question, as I do not face this problem on other notebooks (Dell). The case is the following:

  • ALSA sound is working fine. mplayer plays mp3 test files with sound over the speakers.
  • jackd starts without errors
  • Playing the same file with mplayer -ao jack test.mp3 produces no error. jackd happily connects the mplayer outputs to the system playback. mplayer also runs without error.
  • There is no sound.

There is another question for the same subject, unfortunately without answer. The title says "Mac Power Book", but it's actually about the very same MacBookPro11,2 that I use as well. The technical details there also apply to my case.

Edit: Here is a log I get from qjackctl, showing the sequence from starting to stopping jackd, with a connection from mplayer in the meantime. It does not complain when playing audio, but at the very beginning after the German message, there are 5 lines with strange content. They read like errors, but then it seems to start over and doesn't complain.

23:24:58.948 D-BUS: JACK-Server startet...
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
23:24:58.959 D-BUS: JACK-Server wurde gestartet (org.jackaudio.service aka jackdbus).
Mon Aug 14 23:24:58 2017: Starting jack server...
Mon Aug 14 23:24:58 2017: JACK server starting in realtime mode with priority 10
Mon Aug 14 23:24:58 2017: self-connect-mode is "Don't restrict self connect requests"
Mon Aug 14 23:24:58 2017: Acquired audio card Audio1
Mon Aug 14 23:24:58 2017: creating alsa driver ... hw:PCH|hw:PCH|1024|2|44100|0|0|nomon|hwmeter|-|32bit
Mon Aug 14 23:24:58 2017: configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
Mon Aug 14 23:24:58 2017: ALSA: final selected sample format for capture: 32bit integer little-endian
Mon Aug 14 23:24:58 2017: ALSA: use 2 periods for capture
Mon Aug 14 23:24:58 2017: ALSA: final selected sample format for playback: 32bit integer little-endian
Mon Aug 14 23:24:58 2017: ALSA: use 2 periods for playback
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:capture_1'
Mon Aug 14 23:24:58 2017: New client 'system' with PID 0
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:capture_2'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:playback_1'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:monitor_1'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:playback_2'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:monitor_2'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:playback_3'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:monitor_3'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:playback_4'
Mon Aug 14 23:24:58 2017: graph reorder: new port 'system:monitor_4'
23:25:01.091 JACK-Verbindung geändert.
23:25:01.092 Serverkonfiguration nach "/home/test1/.jackdrc" gespeichert.
23:25:01.092 Statistik zurückgesetzt.
23:25:01.108 Client aktiviert
23:25:01.109 Steckfeld deaktiviert.
23:25:01.142 Schaubild der JACK-Verbindungen geändert.
Mon Aug 14 23:25:00 2017: Saving settings to "/home/test1/.config/jack/conf.xml" ...
Mon Aug 14 23:25:01 2017: New client 'qjackctl' with PID 20955
23:25:05.891 Schaubild der JACK-Verbindungen geändert.
23:25:05.946 JACK-Verbindung geändert.
Mon Aug 14 23:25:05 2017: New client 'MPlayer [21081]' with PID 21081
Mon Aug 14 23:25:05 2017: Connecting 'MPlayer [21081]:out_0' to 'system:playback_1'
Mon Aug 14 23:25:05 2017: Connecting 'MPlayer [21081]:out_1' to 'system:playback_2'
23:25:09.557 Schaubild der JACK-Verbindungen geändert.
23:25:09.756 JACK-Verbindung geändert.
Mon Aug 14 23:25:09 2017: Disconnecting 'MPlayer [21081]:out_0' from 'system:playback_1'
Mon Aug 14 23:25:09 2017: Disconnecting 'MPlayer [21081]:out_1' from 'system:playback_2'
Mon Aug 14 23:25:09 2017: Client 'MPlayer [21081]' with PID 21081 is out
23:25:13.422 Client deaktiviert.
23:25:13.497 D-BUS: JACK-Server fährt herunter...
Mon Aug 14 23:25:13 2017: Client 'qjackctl' with PID 20955 is out
23:25:13.502 D-BUS: JACK-Server wurde angehalten (org.jackaudio.service aka jackdbus).
Mon Aug 14 23:25:13 2017: Stopping jack server...
Mon Aug 14 23:25:13 2017: Client 'system' with PID 0 is out
Mon Aug 14 23:25:13 2017: Released audio card Audio1
0

You can run alsamixer in a terminal and check that there is no muted channel when jackd runs. Press F6 to check each soundcard in case there more that one .

Also try to kill pulseaudio before running jackd , not so easy because pulseaudio is auto relaunched, so run these commands:
mkdir .pulse
echo autospawn=no > ~/.pulse/client.conf
pulseaudio -k
Now pulseaudio is stopped, launch jackd.
(later, to revert to normal mode, run echo autospawn=yes > ~/.pulse/client.conf then pulseaudio )

  • Thanks, but it still isn't working. I checked alsamixer as well, and all is unmuted. I edited my question to add a log from qjackctl. – BMX Aug 14 '17 at 21:56
  • BTW: I have upvoted, but I am too junior for my vote to be displayed. – BMX Aug 15 '17 at 10:12
  • You could try to tweak parameters in Qjackctl: audio interface in "parameters" (if more than one). More settings in"advanced" : "output devices", ports, 16bits ... – laugeo Aug 15 '17 at 10:51
  • Oh, I thought I had already tested any combination. But finally that did the trick. The I/O channels were set to default. I have set them to 2 now, and it works. Thanks a lot! – BMX Aug 16 '17 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.