3

Having some problems with Filezilla crashing/closing itself unexpectedly whenever I try to perform an action on a (sftp) remote server, whether that's changing directories, uploading, or downloading a file. It connects just fine, and I can navigate local directories with no problem, but when I try to do anything on any remote server the whole thing shuts down.

The version is Filezilla v3.21.0, compiled for x86_64-pc-linux-gnu, running on Ubuntu 16.04 LTS 64-bit. The Filezilla log files aren't very enlightening:

2017-08-10 14:41:23 4088 1 Status: Connecting to grantshop.ca...
2017-08-10 14:41:23 4088 1 Response: fzSftp started, protocol_version=6
2017-08-10 14:41:23 4088 1 Command: open "grants@grantshop.ca" 22
2017-08-10 14:41:23 4088 1 Command: Pass: ********
2017-08-10 14:41:23 4088 1 Status: Connected to grantshop.ca
2017-08-10 14:41:23 4088 1 Status: Retrieving directory listing...
2017-08-10 14:41:23 4088 1 Command: pwd
2017-08-10 14:41:23 4088 1 Response: Current directory is: "/home/grants"
2017-08-10 14:41:23 4088 1 Command: ls
2017-08-10 14:41:23 4088 1 Status: Listing directory /home/grants
2017-08-10 14:41:24 4088 1 Status: Directory listing of "/home/grants" successful
2017-08-10 14:42:40 4088 1 Status: Retrieving directory listing of "/home/grants/grantshop.ca"...

Uploading/downloading produces similar logs, where the last log line is 7088 3 Status: Starting download of /home/grants/something.txt or something similar.

Running Filezilla from the terminal gets me this:

Reading locale option from /home/user/.filezilla/filezilla.xml
03:36:32 PM: Debug: Failed to connect to session manager: SESSION_MANAGER environment variable not defined
wxD-Bus: Signal from /org/freedesktop/DBus, member NameAcquired
wxD-Bus: Reply with serial 2
wxD-Bus: Reply to RegisterClient, our object path is /org/gnome/SessionManager/Client27
wxD-Bus: CPowerManagementInhibitor: Requesting busy
wxD-Bus: Reply with serial 3
wxD-Bus: Reply: Error: The name org.freedesktop.PowerManagement was not provided by any .service files
wxD-Bus: Falling back to org.gnome.SessionManager
wxD-Bus: CPowerManagementInhibitor: Requesting busy
wxD-Bus: Reply with serial 4
wxD-Bus: CPowerManagementInhibitor: Request successful, cookie is 1943892549
wxD-Bus: CPowerManagementInhibitor: Requesting idle
wxD-Bus: Reply with serial 5
wxD-Bus: CPowerManagementInhibitor: Request successful
wxD-Bus: CPowerManagementInhibitor: Requesting busy
filezilla: symbol lookup error: filezilla: undefined symbol: _ZN2fz18replace_substringsERKNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEEES7_S7_
1
4

I had set up the "deb http://archive.getdeb.net/ubuntu xenial-getdeb apps" repo. Then I installed Filezilla. On 03/27/2018 that gave me Filezilla 3.21. I was using sFTP. It crashed every second and it never successfully transferred any files. (I never tried old FTP.)

Anyway, I removed the "deb http://archive.getdeb.net/ubuntu xenial-getdeb apps" using the Ubuntu SW Center. Then removed Filezilla.

sudo apt-get purge filezilla
sudo apt-get autoremove
rm -fr ~/.config/filezilla

Then I reinstalled filezilla from the default deb repo.

sudo apt-get install filezilla

This gave me version 3.15. It works fine so far.

2
  • Huh, interesting. Maybe 3.21 is just a buggy distro for Ubuntu users. Have you tried using the most recent 3.32 for Debian 9.0? Does it cooperate better?
    – Boxbot
    Apr 3 '18 at 16:16
  • 1
    I got rid of the problems with disconneting after an update to 3.33.
    – Amade
    Jun 12 '18 at 15:38
1

This post on the Filezilla forums says that last-line terminal error can be caused by libfilezilla being out of date, but I don't even have that lib. It is true that my installed version of FZ wasn't up to date, however. Since the package manager doesn't have the most recent version and the official compiling/dependency instructions are gone, I downloaded the Debian 8.0 version.

A test run of the Debian version operated just fine, so I backed up /usr/bin/filezilla and replaced my existing bin and share files with the downloaded ones. Working like a charm now.

4
  • hi @Boxot debian 8.0 is going to prnt.sc/h30hmg version 3.28 but the file is given in tar.gz2
    – Raghu
    Oct 28 '17 at 5:10
  • 1
    How did you do a test run of the Debian 8 version? And where does one find the existing bin & share files that the archive contains in order to replace them. I've searched all over my Ubuntu 16.04 LTS installation and it's all been to no avail. Thanks.
    – Greg
    Nov 17 '17 at 0:50
  • Hey @Greg, for the test run I just downloaded and unpacked the tar to my desktop, and ran the program from there without integrating it into the system proper. Once I confirmed it worked, I copied the relevant files into the usr etc. directories. For the bin and share files, I used /usr/bin/filezilla as mentioned; if that directory doesn't exist on your machine, try using the "locate filezilla" command in terminal.
    – Boxbot
    Feb 4 '18 at 1:50
  • @Raghu I figured as much, but I was hoping the program would update with the system instead of me having to download and unpack and install a tar. :\ Just an inconvenience is all.
    – Boxbot
    Feb 4 '18 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.