1

I'm new to Linux and my custom display resolutions aren't working.

I'm currently using Lubuntu 17.04 on the machine in question and it has the default LXDE GUI desktop environment loaded.

The red box indicates what I currently see on my monitor/TV:

Desktop Screenshot

I'm using following xrandr instructions exactly as I've found them online. Once I've created the new resolution, I check the [Start > Preferences > Display Settings] and I see my newly created resolution in the list, like so:

Display Settings Screenshot

After selecting and hitting 'Apply', the screen goes black for 15 seconds and puts me right back at 1920x1080. I have tried this for sev I am able to select the other, default resolutions and they display correctly (although I only see like a quarter of my desktop, so it's completely unusable). Previously, on Windows, the screen was at (I think) 1844xSomething and it was fine, but there was some black spacing on the left and right sides, if I remember correctly.

Let's get into the details...

==========================================

DETAILS ABOUT THE MONITOR

Here's the TV details:

  • Panasonic LCD TV Model No. TC-L32C3

I found relevant manufacturer specs from the web:

  • Aspect Ratio: 16:9

  • Native Resolution: 1,049,088 (1,366 x 768) (Number of pixels)

  • HDTV Display Capability: Yes (1080p, 1080i, 720p)

  • Aspect Control: 480i/p: Full, Just, 4:3, Zoom 1080i/p: Full, H-Fill, Just, 4:3, Zoom

  • Panel Drive: 60 Hz

==========================================

Below, I'll describe the steps I took using xrandr and both CVT/GTF for modelines...

STEPS WITH XRANDR & CVT

Step 1:

cfarmer@MEDIA-PC:~$ xrandr Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192 DVI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 698mm x 392mm 1920x1080 60.00 + 59.94* 24.00 23.98
1920x1080i 60.00 59.94
1280x720 60.00 59.94
1440x480i 59.94
720x480 60.00 59.94
720x480i 60.00 59.94
640x480 60.00 59.94
1280x768_60.00 59.87
DIN disconnected (normal left inverted right x axis y axis) DVI-1 disconnected (normal left inverted right x axis y axis)

Step 2:

cfarmer@MEDIA-PC:~$ cvt 1366 768 60.00 # 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

Step 3:

cfarmer@MEDIA-PC:~$ xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

Step 4:

cfarmer@MEDIA-PC:~$ xrandr --addmode DVI-0 1368x768_60.00

Step 5:

I then select it from Display Settings and hit "Apply". The screen goes black for 15 seconds, then reverts to the 1920x1080 default resolution

Step 6: This is the resulting xandr query...

cfarmer@MEDIA-PC:~$ xrandr Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192 DVI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 698mm x 392mm 1920x1080 60.00 + 59.94* 24.00 23.98
1920x1080i 60.00 59.94
1280x720 60.00 59.94
1440x480i 59.94
720x480 60.00 59.94
720x480i 60.00 59.94
640x480 60.00 59.94
1368x768_60.00 59.88
DIN disconnected (normal left inverted right x axis y axis) DVI-1 disconnected (normal left inverted right x axis y axis)

STEPS WITH XRANDR & GTF

Step 1:

cfarmer@MEDIA-PC:~$ xrandr Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192 DVI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 698mm x 392mm 1920x1080 60.00*+ 59.94 24.00 23.98
1920x1080i 60.00 59.94
1280x720 60.00 59.94
1440x480i 59.94
720x480 60.00 59.94
720x480i 60.00 59.94
640x480 60.00 59.94
DIN disconnected (normal left inverted right x axis y axis) DVI-1 disconnected (normal left inverted right x axis y axis)

Step 2:

cfarmer@MEDIA-PC:~$ gtf 1366 768 60 # 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz Modeline "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync

Step 3:

cfarmer@MEDIA-PC:~$ xrandr --newmode "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync

Step 4:

cfarmer@MEDIA-PC:~$ xrandr --addmode DVI-0 1368x768_60.00

Step 5:

I then select it from Display Settings and hit "Apply". The screen goes black for 15 seconds, then reverts to the 1920x1080 default resolution

Step 6: This is the resulting xandr query...

cfarmer@MEDIA-PC:~$ xrandr Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192 DVI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 698mm x 392mm 1920x1080 60.00*+ 59.94 24.00 23.98
1920x1080i 60.00 59.94
1280x720 60.00 59.94
1440x480i 59.94
720x480 60.00 59.94
720x480i 60.00 59.94
640x480 60.00 59.94
1368x768_60.00 60.00
DIN disconnected (normal left inverted right x axis y axis) DVI-1 disconnected (normal left inverted right x axis y axis)

==========================================

As you can see, there are no visible errors anywhere and, compared to the tutorials I'm following, it appears I am doing things correctly. I haven't really seen anybody complain about these steps not working for them, only about "how to make the change permanent" (which I'm sure I can figure out, assuming I can make it work for a single session).

Can somebody please help me figure out what's going wrong?

[IMPORTANT NOTE: For some reason, it changes 1366x768 to 1368x768 in the CVT example. This doesn't seem to be the issue because I've tried these steps with other resolutions where that did not occur (such as 1936x1089), and the display still turned black for 15 seconds before reverting to the previously assigned, default resolution]

UPDATE: ^The occurrence above has been clarified. cvt -v returns a warning about how 1366 isn't a valid cvt format, then it changes it to 1368 in the output (just like it does without the -v flag)

UPDATE: Upon further reading, my graphics card may be relevant. lspci returns: VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV670 [Radeon HD 3870] It's probably pitifully outdated, could this be relevant?

UPDATE: I did all these steps on a laptop with lubuntu installed, and it worked perfectly. I also noticed that all the resolutions had my start menu, task bar, and desktop icons placed where they are supposed to go. This does not happen with the machine in question. At the current, default resolution, the task bar/start menu don't appear at all, they are ~20 pixels below the screen. I only see a fraction of my top left desktop icon as well. I'm not certain it's a xrandr problem anymore so much as some weird anomaly with the TV I'm using. If I change the monitor to a much lower resolution, the display sort of "zooms in" and I can only see some random, empty spacing on the background. Start menu is nowhere to be found and no desktop icons. Hope this helps someone figure out what's going on~

  • Obviously your new resolution in incompatible with your monitor. You can not just run xrandr and use some random settings as you can see. What command did you run with xrandr ? Also, rather then posting links to screen shots, copy paste your terminal output here. – Panther Aug 10 '17 at 16:21
  • The desktop screenshot and display settings screenshot are now available at the top of the article. I've also reformatted my steps with the code tags. Added a few updates as well. Thanks for your quick response~ – Acryce Aug 10 '17 at 19:45
  • Found a related link: ubuntuforums.org/showthread.php?t=1795124 I can't really get any of those solutions working though (they're geared toward Nvidia graphics cards-- my machine is running an ancient Radeon HD 38xx card) – Acryce Aug 11 '17 at 16:49
  • What driver are you using ? I reviewed your commands and there is no obvious error so your hardware may not support your settings. You can file a bug report ... – Panther Aug 11 '17 at 18:13
  • Thanks for your efforts-- I finally found the solution. I'm marking this solved and moving on – Acryce Aug 13 '17 at 0:28
1

After an exhausting search for answers, I found out that the problem I was having was related to "overscan". Google it, if you've never heard of it.

My particular TV setup (likely) doesn't enforce overscan when the video input is considered "computer input". Because of the age of this particular TV, the only way for video input to be considered "computer input" is if the video input comes into the TV via VGA cable. I'm using HDMI input into the TV-- thus, overscan is being enforced.

xrandr happens to have a rather convenient solution for this problem:

xrandr --output DVI-0 --set underscan on xrandr --output DVI-0 --set "underscan hborder" 47 --set "underscan vborder" 26

Change "DVI-0" to whatever your connected output is (use xrandr to figure out which that is) and then edit the numbers 47 and 26 to whatever numbers work for your particular display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.