0

I have an NTFS partition so I can share with a dual-booted Windows installation. chmod doesn't do anything, nor issue a warning to indicate this.

I want other (Ubuntu) users to have RW permissions on certain files.

brian@brian-t1:/media/Storage/Documents/Scratch Projects$ ls -l    
-rw------- 1 brian brian      5 2012-01-11 02:18 testfile
brian@brian-t1:/media/Storage/Documents/Scratch Projects$ chmod go+rw testfile
brian@brian-t1:/media/Storage/Documents/Scratch Projects$ ls -l
-rw------- 1 brian brian      5 2012-01-11 02:18 testfile

What is wrong here?

1

Disclaimer - I would use a Linux native file system as NTFS is likely to get complicated and may not work.

If you must use ntfs, mount the ntfs partition with the option permissions.

Edit /etc/fstab

# Graphical 
gksu gedit /etc/fstab

# Command line
sudo -e /etc/fstab

Add an entry

/dev/sda2  /media/ntfs ntfs-3g  permissions,locale=en_US.utf8   0   2

chown and chmod will now work.

However ...

  1. My understanding is Microsoft made some changes to ntfs and some people report they can not read files written to a NTFS drive from Ubuntu.

  2. You may well need to map users. See http://b.andre.pagesperso-orange.fr/permissions.html

  • thanks for the reply. I was tearing my hair out on this one until I found out about the lack of support on NTFS. I had followed the suggestions of a user who had shown how to have win & Ubuntu live side by side & they had the storage shared drive as NTFS. I live and learn. – brianp Jan 13 '12 at 12:18
  • I've seen newer answers with different techniques. Just wondering if you'd like to modernize this ~7 year old answer or leave as is? – WinEunuuchs2Unix Nov 12 '17 at 14:01
  • @WinEunuuchs2Unix as far as I know it still works, did you find a problem ? – Panther Nov 12 '17 at 17:04
  • @Panther not sure, I used a different answer you posted on another thread: UUID=5CCC5867CC583E08 /mnt/c ntfs-3g permissions,locale=en_US.utf8 0 2 – WinEunuuchs2Unix Nov 12 '17 at 17:28
  • Those are not bad options =) – Panther Nov 12 '17 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.