0

My Hauppauge WinTV Ministick doesn't work on 16.04.3. As the linux-firmware-nonfree isn't supported anymore, I installed the driver myself in /lib/firmware. I found the file sms1xxx-hcw-55xxx-dvbt-02.fw here.

The adapter worked fine with Ubuntu 14.04 with the same firmware (and works today in windows too). So it is not a problem due to the adapter but it seems to be a problem between the firmware and the new kernel.

The driver is recognized by dmesg (see below) but with kaffeine it doesn't work :

  • It is able to find the channels,
  • But when I try to see a channels, the screen becomes blank and the system crashes !

Can someone help me ?

Thank you !

Output of dmesg :

[ 7329.648272] usb 2-2: new high-speed USB device number 4 using ehci-pci
[ 7329.797205] usb 2-2: New USB device found, idVendor=2040, idProduct=c000
[ 7329.797212] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7329.797217] usb 2-2: Product: WinTV MiniStick
[ 7329.797221] usb 2-2: Manufacturer: Hauppauge Computer Works
[ 7329.797225] usb 2-2: SerialNumber: 4033980053
[ 7330.935871] smsusb:smsusb_probe: board id=8, interface number 0
[ 7331.480054] Registered IR keymap rc-hauppauge
[ 7331.480302] input: SMS IR (Hauppauge WinTV MiniStick) as /devices/pci0000:00/0000:00:1d.7/usb2/2-2/rc/rc0/input19
[ 7331.480487] rc rc0: SMS IR (Hauppauge WinTV MiniStick) as /devices/pci0000:00/0000:00:1d.7/usb2/2-2/rc/rc0
[ 7331.495547] lirc_dev: IR Remote Control driver registered, major 241
[ 7331.534345] rc rc0: lirc_dev: driver ir-lirc-codec (smsmdtv) registered at minor = 0
[ 7331.534348] IR LIRC bridge handler initialized
[ 7331.545973] IR RC5(x/sz) protocol handler initialized
[ 7331.572321] smsusb:smsusb_probe: Device initialized with return code 0
[ 7331.622630] dvbdev: DVB: registering new adapter (Hauppauge WinTV MiniStick)
[ 7331.622816] usb 2-2: DVB: registering adapter 0 frontend 0 (Siano Mobile Digital MDTV Receiver)...
[ 7331.625956] smsdvb:smsdvb_hotplug: DVB interface registered.
[ 7331.626439] usbcore: registered new interface driver smsusb

Output of lsusb :

Bus 002 Device 004: ID 2040:c000 Hauppauge Windham
3
  • I have an old computer [doc.ubuntu-fr.org/toshiba_satellite_p300-27z] with a windows Vista dual boot and no UEFI bios. – Oli Aug 9 '17 at 16:27
  • You should then open Additional drivers. If additional firmware is required it should be offered. – user692175 Aug 9 '17 at 16:34
  • Here is the output of meloli@portable:~$ sudo ubuntu-drivers list gives intel-microcode Nothing linked with my hauppauge stick ... I've tried to remove the file sms1xxx-hcw-55xxx-dvbt-02.fw which I putted in \lib\firwmare. Same answer from ` ubuntu-drivers list`. – Oli Aug 10 '17 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.