Today I was unable to open Discord without updating it to the 0.0.2 version. I attempted to install it using the .deb file but when clicking on "install", nothing happened. So I installed it using the .tar.gz file with these commands:

sudo ln -s /usr/share/discord/discord.desktop /usr/share/applications/
sudo ln -s /usr/share/discord/discord.png /usr/share/icons/
sudo ln -s /usr/share/discord/Discord /usr/bin/discord

When I opened the application I just got a blank screen: Screenshot of Discord 0.0.2

  • Are the permissions on this executable right? Why don't you just run the /usr/share/discord/Discord or the desktop file (look what's inside maybe paths aren't right) and see if it works. The thing you did atm. was only creating symlinks.
    – Ziazis
    Aug 9, 2017 at 11:23
  • I ran the executable, same result.
    – Ajali
    Aug 9, 2017 at 14:50

1 Answer 1


I encountered the same issue today. Here is how I managed to solve it.

  1. Remove discord

  2. Download the discord .deb file and install it:

    sudo dpkg -i my_discord_deb_file.deb
  3. fix missing dependencies:

    sudo apt-get -f install
  4. re-run:

    sudo dpkg -i my_discord_deb_file.deb

N.B: I don't know if all the steps are necessary, but it worked for me.


Not the answer you're looking for? Browse other questions tagged or ask your own question.