0

I've gotten myself a Steinberg UR22mk2 USB audio interface. After plugging it into my Linux system (Kubuntu 17.04 with kernel 4.10.0) it is automatically and correctly detected.

The problem I have is: whenever an certain applications (re) opens an audio output channel and plays back audio via the UR22mk2 with the earphones connected to it, there's an unwanted and slow audio fade in. It happens in Kdenlive, but neither VLC nor Audacity.

This is very annoying when editing video+audio in Kdenlive, because whenever stopping playback and restarting it in order to find the correct cut positions, the automatic audio fade in kicks in and makes editing unusable with the Steinberg. My Behringer QX1202USB doesn't exhibit this behavior. However, both seem to use the same stock USB audio Linux kernel module.

This only happens with the Steinberg UR22mk2 USB audio interface, but not with other USB audio interfaces, such as my Behringer UX1202USB audio interface. This is not a hardware feature, but software: when I connect the UR22mk2 to an Android tablet, there's no audio fade-in, but the audio playback is immediately present as it should.

Is there a hidden (and probably not well-documented) driver setting for the UR22mk2 to disable this audio fade in? Or is there some Linux audio system setting(s)? I've looked around and searched and searched ... but to no avail so far.

Any suggestions?

0

Some more digging shows that the unwanted 2 secs audio fade-in happens only with some applications, most notably the Kdenlive video editor (and also MLT/melt), but not others, such as VLC media player and (phew!) the indispensable Audacity audio editor.

Luckily, I've now found a setting that allows me to work with the Steinberg UR22mkII in Kdenlive without any annoying fade-in, see below (spoiler: use ALSA as the audio driver setting).

But first for details: audio in VLC just works fine, with its audio output module set to

  • automatic
  • pulseaudio
  • ALSA

Audacity only has "ALSA" and "OSS" anyway, but no PulseAudio. So the plot thickens.

In contrast, Kdenlive behaves either good or bad, depending on its audio driver settings (but the audio backend doesn't matter, regardless whether it's "SDL" or "RtAudio"):

  • automatic: fails with annoying 2s audio fade-in.
  • PulseAudio: fails also with 2s audio fade-in.
  • ALSA: finally works as expected without any unwanted 2s audio fade-in.

Maybe someone can shed some light in the comments on why PulseAudio behaves differently when used by some applications compared to other applications; could be different API calls, per chance?

3
  • Maybe similar to problem I have seen with other interfaces that sometimes power down when playing from pulseaudio. Leaving Pulseaudio Volume Control (pavucontrol) mixer open was enough to keep usb device on
    – nik gnomic
    Dec 24 '17 at 18:01
  • now that's another interesting twist I'll test!
    – TheDiveO
    Dec 24 '17 at 18:03
  • If fade-in is due to interface powering off when no audio playback in pulseaudio use JACK sound server and interface will not power down. JACK is better environment to control and mix audio than Pulseaudio. Audio connections are permanent and static, not like audio streams in Pulseaudio
    – nik gnomic
    Dec 26 '17 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.