0

I've tried to get the mir-kiosk snap on Ubuntu Core, on a Raspberry Pi 3, running. Installation progress went fine, using these two tutorials; * http://voices.canonical.com/alan.griffiths/2017/01/31/mircade-snap/ * http://www.lieberbiber.de/2017/02/27/mir-and-graphics-on-ubuntu-core/

One person has made a comment about it working flawlessly on Raspberry Pi 3, but it doesn't on my side. I've tried the suggested "snap connection" without any luck.

I don't get any error messages. Have tried many reboots and reinstalls.

Any suggestions?

The pi have both Ethernet and WiFi connection. Connected to a 40 TV through HDMI.

4
  • Contact the person who maintains those packages. – Panther Aug 8 '17 at 17:55
  • Hm, thought if someone has a suggestion I could try out, I wouldn't have to bother him with such questions. – Joachim Aug 8 '17 at 18:00
  • Well you can hope someone with more experience with these packages come along. – Panther Aug 8 '17 at 18:09
  • Yeah, sure. That's why I'm posting here. – Joachim Aug 8 '17 at 19:22
1

I happened to be trying this just last week, and stumbled across a bug which I presume was causing your problems:

https://forum.snapcraft.io/t/opengl-interface-change-in-master-broke-gles-on-the-pi-devices/1947/5

There is a workaround mentioned there, but a newer core snap has the proper fix integrated.

So I'd recommend using the Daily/Edge RPi3 image available here (it also has reliably working wifi). Next install the core snap from the edge channel, and then you can follow Alan Griffith's guide.

-G

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.