I am completely new to Ubuntu. My system, which is 3 days old is not allowing me to launch unity. Up until now I have needed to run

 sudo systemctl restart lightdm.service

To launch it. This morning during a computationally intensive run of deeplearning my system crashed (everything froze and I needed to do a hard reboot). Since then, when I try to launch Unity I get a blank screen with a flashing cursor.

I ran

 exec sudo -i

and tried this

is there a command to factory reset Ubuntu?

I have reinstalled lightdm, unity and ubuntu-desktop.

I also tried this

(13.04) lightdm crashing - black screen flashing cursor

and have tried this

Ownership of .Xauthority transferred to root

Nothing is working, however I am getting this error message:

 [331.322881] pcieport 0000:00:02.0: PCIe Bus Error: severity-Corrected, type=Data Link Layer, id=0010(Receiver ID)
 [331.323119] pcieport 0000:00:02.0: DEVICE [8086:6F04] error status/mask=00000080/00002000
 [331.323119] pcieport 0000:00:02.0: [7] Bad DLLP

I have no idea what this means or how to debug it. Could someone offer some guidance please.


Having to manually restart lightdm is not normal. Especially for a new Ubuntu installation.

First I'd recommend checking that you have the latest BIOS installed for your motherboard, and the latest firmware and drivers for your Nvidia/GPU video card.

The PCIe error is your GPU. If you have multiple GPU's, you may need to test one GPU at a time, to eliminate a single failure or seating problem.

If firmware and drivers don't fix the problem, you may need to add kernel boot time options to cure it. Please see https://forums.lime-technology.com/topic/50821-solved-logs-filling-up-with-aerpcie-bus-errors/ for one example.

A Google search for "device id 8086:6F04" will give you more information.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.