3

I have an ASUS G701VIK where I have installed two NVME SSD 960 Pro M.2. The system has Windows 10 running on the same two drives and works correctly.

On disk 1 (GPT) I have the following partitions:

  • Recovery NTFS 450 MB
  • FAT32 100Mb (EFI System Partition)
  • Other 16Mb (Reserved Partition)
  • C:(NTFS) 493 Gb (shrunk using Mini Tool Wizard to create the next)
  • (Ext4) 460 GB

There is also a Disk 2, with just one NTFS Volume.

I have disable Secure Boot and Fast Boot on the BIOS of the machine.

I have created a bootable USB drive using Win32DiskImager, for Ubuntu 16.04 LTS and 17.04 with the same result.

The computer boots from the USB, during boot I modify the GRUB boot script to include: nouveau.modeset=0 (that is necessary for the graphics card) and also have tried adding nvme_load=YES and remove quiet splash

If I go to the GRUB command line and type ls -all I get the list of devices, where the partition types are correctly recognized except for the 3rd one.

It also complains about some efi files being missing: tar.mod, sfs.mod, nilfs2.mod, minix.mod, afs.mod, affs.mod.

In all cases, the result is that during the installation process the only drive that is recognized is the USB Drive, but not the M2 SSD drives.

I have read many posts all in this and other forums but haven't found any that helps me. I have also contacted the manufacturer and I am waiting for an answer (not that I have great hopes of them solving the issue for me).

The idea is to setup dual boot with Windows 10.

I am quite newbie on Ubuntu and Linux in general. Please ask for anything you think may be relevant to the problem and I haven't mentioned.

grub console

select disk to install

EDIT: answering the questions below, there is no nvme driver in the list, just PCIe. The only errors are related to wifi how to install the driver? is nvme_load the command?

Fast boot is disabled, as it is Secure Boot.

EDIT2: Adding links to the outputs of all 3 commands requested: (I haven´t run nvme_load this time)

lspci -k output
lsblk output
dmesg output

  • What I would do is install the boot loader on the ssd that you install Ubuntu on. Have you done that? – MathCubes Aug 10 '17 at 21:48
  • 1
    No, I haven't. how can I do it? I am quite new to Linux. – Picarus Aug 10 '17 at 23:41
  • the easiest way for you would probably be just reinstall it with a different, new downloaded ISO file, and for the select the SSD where you want to install it on as the boot loader location. – MathCubes Aug 10 '17 at 23:42
  • is this something I can do from Windows? What software do I need to use? Ubuntu doesn't see the SSD but GRUB does. – Picarus Aug 10 '17 at 23:57
  • What happens if you put in the live USB flash drive and boot into it? – MathCubes Aug 10 '17 at 23:58
1
+100
00:17.0 RAID bus controller: Intel Corporation SATA Controller [RAID mode] (rev 31)
    Subsystem: ASUSTeK Computer Inc. SATA Controller [RAID mode]
    Kernel driver in use: ahci
    Kernel modules: ahci

[    9.805918] ahci 0000:00:17.0: Found 2 remapped NVMe devices.
[    9.805918] ahci 0000:00:17.0: Switch your BIOS from RAID to AHCI mode to use them.

dmesg has given you the solution. For whatever reason, the kernel requires the SATA controller to be in AHCI mode instead of RAID mode to allow you to use the two NVMe drives. So changing the mode in BIOS/UEFI settings should do.

Edit: apparently in some machines, the RAID mode is hardcoded and the user cannot make changes to that in the BIOS/UEFI settings. In that case, it is impossible (as of today, at least) to use the NVMe drives in Linux:

https://github.com/torvalds/linux/commit/aecec8b60422118b52e3347430ba9382e57d6d76

Also see replies in this thread for more details:

http://marc.info/?l=linux-ide&m=147709610621480&w=2

Your only chance will be to see if the vendor provides firmware update that allows you to change the mode to AHCI. You may also try request alternative firmware build by seeking technical support directly from the vendor, though you are likely to be out of luck on that.

  • The BIOS doesn't have an AHCI mode. In the SATA configuration there is only one mode: Intel RST Premium. The question is if Windows can manage the disks not being on RAID, how make Ubuntu do the same? – Picarus Aug 13 '17 at 8:02
  • You can't. github.com/torvalds/linux/commit/… – Tom Yan Aug 13 '17 at 9:34
  • To be honest I didn't understand why the ahci driver is involved at all. Apparently it's yet another dirty deed of Intel and some other vendors. If you are interested in the details maybe this the replies to this thread would help a bit: marc.info/?l=linux-ide&m=147709610621480&w=2 – Tom Yan Aug 13 '17 at 9:38
  • I wonder how these NVMe drives are exposed under Windows. As SATA drives maybe? A screenshot of your device manager expanded could be interesting. Not gonna help you getting out of this mess though. – Tom Yan Aug 13 '17 at 9:41
  • TL;DR, say bye bye to Linux (not just Ubuntu) if you need to stick with this laptop and NVMe drives, at least for now. – Tom Yan Aug 13 '17 at 9:43
0

the same with me, an HP EliteBook with M2 NGFF. Ubuntu live boot ok but can't install. Error noted that "Can't configure your hardware..." My Solution: replace a HDD to SATA slot and change boot order to legacy, and then install Ubuntu on HDD and Windows 10 on M2 PCIe NGFF

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.