0

I'm trying to completely delete a program and its associated files to I can to a clean install, but it wont allow me too delete the final 4 files. Every time I try it gives me this,

    Error removing file /media/nunyah/bf8e3bed-a0b9-4929-b303-7d7c210aafa1/var/lib/app-info/icons/ubuntu-zesty-multiverse/64x64/steam-installer_steam.png: Permission denied

What should I do?

  • Permissions? Did you use 'sudo rm -rf'? – phandolin Aug 7 '17 at 23:39
  • no i tried dragging them to the trash, and after it told me i couldn't do that i right clicked the programs and tried that way. – xwing Aug 8 '17 at 0:31
  • how would i use 'sudo rm -rf' to delete the programs ? – xwing Aug 8 '17 at 0:32
0

The file you are trying to delete might have been being used by another program. If you sure it was not then open a terminal with Ctrl + Alt + T and use:

sudo rm /media/nunyah/bf8e3bed-a0b9-4929-b303-d7c210aafa1/var/lib/app-info/icons/ubuntu-zesty-multiverse/64x64/steam-installer_steam.png

Please note anything starting with /media could be a SD Card mounted as read-only which means you can't delete it in the first place.

To close the terminal window you can click X on the window top corner, press Ctrl + C or type exit and press Enter.

Please let us know your progress because many people perform "drive byes". Welcome to Ask Ubuntu :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.