3

I have a number of "gaming" mice with extra buttons, including a Logitech G602, Corsair Scimitar, Razer Naga, etc. All of these mice seem to exhibit a common bug using Ubuntu, that is when pressing an input button on the mouse and one on the keyboard at the same time, the focused window freezes for a few seconds. In some things like games, that's a huge problem. In web browsers and so on it's annoying, but not a big issue.

Is there a known fix to this issue or is there a driver I should be specifically using that might alleviate it? Note that I'm using unofficial third party drivers for all the mice, but I'm fairly confident it's an issue with the OS, not the input device, since it's common between three devices and countless applications.

Right now I'm using Ubuntu 17.04 with Gnome nut I've seen this on Unity, Kubuntu, elementary, and Xubuntu, on 14.04, 16.04, and 17.04 in various configurations.

Mouse driver for current configuration (Corsair Scimitar) is CKB: https://github.com/ccMSC/ckb

Keyboard right now is KBC Poker 3 using whatever default driver is selected for it. I've got a few other boards around and a Ducky Shine TKL produced the issue, as did a Razer BlackWidow.

Computer specifications: AMD FX8350, Gigabyte 990fxa-ud3 (known to have some USB issues, but the 4 working ports are all behaving the same), EVGA GTX770SC graphics card.

10
  • 1
    Try enable TouchPad while typing, Mouse > Touchpad > and uncheck "disable touchpad while typing" and let me know if it's fixed, or change the USB ports of mouse and keyboard to different ports or test with different mouse 🖱 and keyboard (in PC) – αғsнιη Aug 11 '17 at 5:30
  • 1
    "I'm using unofficial third party drivers for all the mice" Can you edit your question with the names and versions of these drivers? Also any other relevant information about your platform: computer make, model, CPU, etc. – WinEunuuchs2Unix Aug 14 '17 at 0:07
  • Check if ~/.xsesssion-errors has errors for when you reproduce the problem. Also run strace with some app, e.g. strace gedit from a terminal, reproduce the bug, and check if strace output stops for when the window freezes. If it is, then add to the post, say, 8-9 lines of the output with a mark at which line did it hang. – Hi-Angel Aug 14 '17 at 11:00
  • @αғsнιη No options for disabling touchpad while typing, this is a desktop computer. Tried a few ports, but most are non-functional so I only have 6 to choose from (motherboard has known issues booting some USB ports). Thanks. – XtrmJosh Sep 15 '17 at 10:26
  • @Hi-Angel No ~/.xsession-erors, I'm on Gnome DE at the minute, so I guess Gnome Shell would be the equivalent? Not sure what to look at. Thanks. – XtrmJosh Sep 15 '17 at 10:26
1

I would have left a comment, but I haven't enough reputation. I had a similar problem and the problem was the graphic driver.

Every time the freeze happened, the system log file (/var/log/syslog) contained lines like this:

... kernel: [drm] GPU HANG: ecode 9:0:0x84dffff8, in Xorg [2082], reason: Hang on render ring, action: reset
... kernel: drm/i915: Resetting chip after gpu hang
... kernel:  [drm] RC6 off
... kernel:  [drm] GuC firmware load skipped

The solution was to disable SNA if favor of UXA acceleration.

2
  • I'm not seeing anything in syslog, is it possible that you've enabled some enhanced logging for this reason? – XtrmJosh Sep 13 '17 at 0:28
  • I think this qualifies as an answer. Plus it's too large to fit into a comment with proper formatting. – WinEunuuchs2Unix Sep 15 '17 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.