4

For some reason the sidebar and the top bar disappeared on my Ubuntu 14.04. Ctrl+Alt+t does not start a terminal. I tried to remove .config and .cache/compizconfig-1, I tried to restart and reinstall unity, but to no avail.

I have some files on my desktop. If I open them, the corresponding application starts but the menu at the top does not show.

I also tried to use ccsm as suggested here Unity doesn't load, no Launcher, no Dash appears but it did not work.

2 Answers 2

5
  1. Open a tty terminal: Ctrl+Alt+F1.

  2. Next, log into your account and run the following commands:

sudo rm -rf ~/.cache/compizconfig-1
sudo rm -rf ~/.compiz
sudo rm -rf ~/.Xauthority
sudo dconf reset -f /org/compiz/
setsid unity
sudo reboot
3
  • Thanks a lot! sudo rm -rf ~/.Xauthority was the only thing I had not tried. Commented Aug 7, 2017 at 19:40
  • 2
    Why are you using sudo to delete folders in home directory?
    – pomsky
    Commented Mar 28, 2018 at 23:06
  • I can't seem to be able to type the sign ~ Everytime I try, I only get " I use international type o keyboard, so I don't know what's the cause of this. Anyway, now I can't fix my Unity problem due to a missing ~ !!!!!! Commented Oct 3, 2018 at 13:01
1

You just need to open Settings → Dock → Position on Screen and choose one of them. The icons will reappear.

1
  • I don't understand where is Dock in settings application. P.S. I found it, another settings category was selected. You need to go back to all settings, becase it shows last settings you have used not all category settings from scratch. Commented Feb 9, 2022 at 18:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .