2

I just got this Acer Aspire ES14 and wanted to throw some debian based distro on it. After many attempts I still cant get it to work.

Install seems to go just fine no problems (from USB) after it tells me to reboot I get the 'No Bootable Device'.

After googling for a bit I found a couple of solutions

Dont use UEFI but legacy mode -> not an option in my BIOS

Select a UEFI file of some sorts -> Cant do that either, only options are 'Erase all secure boot setting' and 'Restore Default'

Enable/disable secure boot -> tried both, same results

If somebody could help me I would be so gratefull, I'm getting desparate.

Link to boot repair utility here.

4
  • does your system have OS boot options or only device boot options? – ravery Aug 7 '17 at 17:56
  • Not sure what you mean but I guess you mean in the boot priority whether it says the device or the os? In that case i can only choose the device from which to boot. – stilllearning Aug 7 '17 at 19:13
  • Please run the Boot Repair utility from the Ubuntu installer booted in its "try before installing" mode and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Aug 9 '17 at 14:45
  • [link](paste.ubuntu.com/25284232) I want to install the os on the emmc drive not on the the hard disk – stilllearning Aug 10 '17 at 15:59
0

Device boot requires the default media path - /efi/boot/bootx64.efi in the ESP partition order to boot. So copy /efi/ubuntu/grubx64.efi to /efi/boot/ and rename to bootx64.efi. If you are using secure boot, /efi/ubuntu/shimx64.efi will need to be copied and renamed. Note: you will need to temporarily remove the ESP flag in order to make this change.

3
  • Sadly enough I still get the 'No Bootable Device' – stilllearning Aug 7 '17 at 19:11
  • maybe case sensitive .. try EFI/BOOT/bootx64.efi. I have also seen some systems require a recovery partition to be first. a small ntfs partition flagged as system reserved or recovery – ravery Aug 7 '17 at 19:22
  • Tried both, still nothing though. – stilllearning Aug 7 '17 at 19:40
0

Same problem here. Installing and then changing to Legacy mode didn't work. Boot Repair utility didn't work. Manually selecting (in the BIOS) a .efi file didn't work...

We finally solved the following way:

  1. Go to BIOS (F2) and in the Boot menu, change Boot mode from UEFI to Legacy
  2. Install Ubuntu from a pen drive normally.

This is for an Ubuntu-only installation. No dual boot in our case.

1
  • All Acer need to have latest UEFI from Acer and then set "trust" for UEFI boot files. Acer Aspire E15 will not dual boot, many details Trust settings in step 35 askubuntu.com/questions/627416/… & Acer Very latest UEFI/BIOS works, downgrade not required if no trust screens, you must now upgrade: ubuntuforums.org/… – oldfred Dec 12 '18 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.