3

I have a Dell Inspiron 15 3000 series with Intel core i3-4030u (4th generation).

I dual boot Windows 10 Home 64-bit and Ubuntu Gnome 16.04 (grub2 is the bootloader).

I was using Chromium when all of a sudden, Ubuntu freezes and will not respond. I did a hard shutdown and tried to restart; but instead of going to the grub2 boot screen where you can choose to boot Ubuntu, Windows, or other options, it went to the grub prompt:

grub> 

If I choose Windows Boot Manager from BIOS, it will start; but ubuntu always goes to the grub prompt.

When I use the ls command, I get this output:

(hd0) (hd0,gpt9) (hd0,gpt8) (hd0,gpt7) (hd0,gpt6) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (hd1) error: failure reading sector 0x0 from hd1 

Ubuntu is installed in partition 8 on hard drive 0 (hd0,gpt8). I have only 1 hard drive and only 1 hard drive slot, and there is nothing in the CD-ROM; so I don't know why it is trying to access hd1.

I did some research, and tried to boot manually with these commands:

grub> set root=(hd0,8)
grub> linux /boot/vmlinuz-4.10.0-30-generic root=/dev/sda8 ro
grub> initrd /boot/initrd.img-4.10.0-30-generic
grub> boot

I got the vmlinuz and initrd versions by looking in the folder /boot.

When I enter those commands, it tries to boot, and there are a few errors about how systemd could not load some modules when starting services because either it could not find the files or the function is not implemented.
Also, there is an error:

Aug 07 08:46:50 AlexUbuntu kernel: FAT-fs (sda1): IO charset iso8859-1 not found
Aug 07 08:46:50 AlexUbuntu systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
Aug 07 08:46:50 AlexUbuntu systemd[1]: local-fs.target: Triggering OnFailure= dependencies.
Aug 07 08:46:50 AlexUbuntu systemd[1]: boot-efi.mount: Unit entered failed state.
Aug 07 08:46:50 AlexUbuntu systemd[1]: Starting Enable support for additional executable binary formats...

Then it continues starting services.

Then it goes into emergency mode. I accessed the system logs by typing systemctl.
It shows that there are two errors but that everything else was loaded active and some other status such as running or exited:

...
boot-efi.mount                    loaded failed failed   /boot/efi
...
systemd-modules-load.service      loaded failed failed   Load Kernal Modules
...

When I used the command:

systemctl status systemd-modules-load.service

I got some output which contained:

Process: 378 ExecStart=/lib/systemd/system/systemd-modules-load (code=exited, status=1/FAILURE)

When I used:

systemctl status boot-efi.mount

I got output that contained:

Process 534: ExecMount=/bin/mount /dev/disk/by-uuid/6036-A092 /boot/did -t vfat -o umask=0077 (code=exited, status=32)
...
Aug 07 08:46:50 AlexUbuntu mount[537]: mount: wrong fs type, bad option, bad superblock on /dev/sda1,
                                              missing codepage or helper program, or other error

After manually booting once, I now get the grub2 boot screen to choose between boot options again, but when I choose ubuntu, it boots into emergency mode still.

I read something about manually configuring the grub config file, but I have no idea where to start with that.

Is there anything I can do to get it to boot successfully again, or do I have to reinstall Ubuntu?

EDIT:

sudo blkid: (UUID and PARTUUID is left out for the Windows partitions)

/dev/sda1: LABEL="ESP" UUID="6036-A092" TYPE="vfat" PARTLABEL="EFI system partiton" PARTUUID="2ad4eb64-f0c3-457a-9f95-8679a75333a5"
/dev/sda2: LABEL="DIAGS" TYPE="vfat" PARTLABEL="Basic data partition"
/dev/sda3: PARTLABEL="Microsoft Reserved Partiton"
/dev/sda4: LABEL="WINRETOOLS" TYPE="ntfs" PARTLABEL="Basic data partition"
/dev/sda5: LABEL="OS" TYPE="ntfs" PARTLABEL="Basic data partition"
/dev/sda6: TYPE="ntfs"
/dev/sda7: LABEL="PBR Image" TYPE="ntfs" PARTLABEL="Microsoft recovery partition"
/dev/sda8: UUID="421b08b9-5965-45d5-8490-48bd8bf373a5" TYPE="ext4" PARTUUID="c0172335-398f-4094-8344-fdad94a8e5da"
/dev/sda9: UUID="b9ddff1f-4da1-44c0-b9e1-0afe98c3109e" TYPE="swap" PARTUUID="744e5f85-28ed-4f38-b35b-9a3a2cd64494"

cat /etc/fstab: (some comments at beginning of file are left out)

# <file system> <mount point>   <type>  <options>        <dump>  <pass>
# / was on /dev/sda8 during installation
UUID=421b08b9-5965-45d5-8490-48bd8bf373a5 /      ext4   errors=remount-ro 0     1
# /boot/efi was on /dev/sda1 during installation
#UUID=6036-A092  /boot/efi        vfat   umask=0077       0       1
# swap was on /dev/sda9 during installation
UUID=b9ddff1f-4da1-44c0-b9e1-0afe98c3109e  none  swap sw  0       0
UUID=6036-A092   /boot/efi        vfat   defaults         0       1

free -h:

      total    used     free   shared  buff/cache   available
Mem:   3.8G     33M     3.5G     5.9M       241M        3.5G
Swap:  3.9G      0B     3.9G

swapon -s:

Filename     Type       Size    Used     Priority
/dev/sda9    partition  4095996   0         -1

sudo fdisk -l:

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 554B9E62-9C74-4A35-8CDE-6F87341A0BE1

Device         Start       End  Sectors  Size Type
/dev/sda1       2048   1026047  1024000  500M EFI System
/dev/sda2    1026048   1107967    81920   40M unkown
/dev/sda3    1107968   1370111   262144  128M Microsoft Reserved
/dev/sda4    1370112   2906111  1536000  750M Windows recovery environment
/dev/sda5    2906112 577532275 574626164 274G Microsoft basic data
/dev/sda6  952780800 953747455    966656 472M Windows recovery environment
/dev/sda7  953747456 976771119  23023664  11G Windows recovery environment
/dev/sda8  577533952 944588799 367054848 175G Linux filesystem
/dev/sda9  944588800 952780799   8192000 3.9G Linux swap

Partition table entries are not in disk order

Here is a screenshot of gparted:

Screenshot


EDIT 2:

These are some more errors I found in the journal (journalctl -xb):

kernel: PCCT header not found

ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored

kernel: (NULL device *): hwmon_device_register() is deprecated.  Please convert the driver to use hwmon_device_register_with_info().

kernel: r8169 000:07:00.0: can't disable ASPM; OS doesn't have ASPM control

Failed to insert module 'autofs4': No such file or directory

Starting of Arbitrary Executable File Formats System Automount Point not supported

systemd[1]: dev-disk-by\x2dpartlabel-Basic\x5cx20data\x5cx20partition.device: Dev dev-disk-by\x2dpartlabel-Basic\x5cx20data\x5cx20partition.dev


I think this is the main problem:

[FAILED] Failed to start Load Kernal Modules.
See 'systemctl status systemd-modules-load.service' for details.


systemctl status systemd-modules-load.service output:

 systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vender preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-08-07 15:21:20 EDT; 11min ago
      Docs: man:systemd-modules-load.service(8)
            man:modules-load.d(5)
 Process: 374 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 374 (code=exited, status=1/FAILURE)

systemd[1]: Starting Load Kernel Modules...
systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: Failed to start Load Kernel Modules.
systemd[1]: systemd-modules-load.service: Unit entered failed state
systemd[1]: systemd-modules-load-service: Failed with result 'exit-code'.


EDIT 3:

I was using vmlinuz and initrd version 4.10.0-30-generic. When I booting using 4.10.0-27-generic, I still got the error about Kernal Load Modules, but it booted successfully.

However, I got a System Program Error a few seconds after it started. I reported the problem, and then it said Ubuntu 16.04 experienced an internal error.

The package colord crashed and it said that the cause was obsolete packages and that I need to update some packages.

Some of the packages I updated were: systemd, libsystemd0, libpam-systemd, and libkmod2

Now it boots successfully in vmlinuz and initrd version 4.10.0-27-generic and 4.10.0-30-generic.

  • 2
    Have you tried the boot-repair disk? help.ubuntu.com/community/Boot-Repair – Afforess Aug 7 '17 at 18:06
  • From emergency mode, edit your question to include the output of sudo blkid and cat /etc/fstab and free -h and swapon -s and sudo fdisk -l and I'll take a look for you. Start new comments to me with @heynnema or I may miss them. – heynnema Aug 7 '17 at 19:41
  • When I did a Recommended Repair with the boot-repair disk, all it did was add options to the grub boot menu. Here is the link: paste.ubuntu.com/25264901 – alexm Aug 7 '17 at 19:50
  • I was able to boot into Ubuntu recovery mode and update grub, but it did not fix anything. I don't think grub is the problem. – alexm Aug 7 '17 at 19:56
  • @heynnema Ok I included the output of those commands. – alexm Aug 7 '17 at 20:39
1

I fixed the problem by booting into a different kernel version and updating packages.

To boot with a different kernel version:

On the grub2 boot menu, instead of selecting ubuntu or Windows Boot Manager, select Advanced Options for Ubuntu; then select the second latest version you have (not recovery mode).

To update the packages:

Open a terminal and type:

sudo apt install --upgrade systemd libsystemd0 libpam-systemd libkmod2
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.