10

I'm trying to install steamcmd on a Ubuntu 16.04 LTS server, but when running sudo apt-get install steamcmd it errors out with

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package steamcmd

I've already updated and upgraded. How can I resolve this problem?

11

Ok, I found the answer myself.

First I needed to add multiverse to my /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu xenial main universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates main universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-security main universe multiverse

afterwards I added the i386 architecture:

sudo dpkg --add-architecture i386

now after an apt-get update I am able to install it.

sudo apt-get install steamcmd
3

Run these commands:

sudo add-apt-repository multiverse 
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install lib32gcc1 steamcmd

Hope this will help. Or you can check source here:

  • I'm not sure what people think is wrong with this post. It's not really the same method as that answer, though it should have the same effect. When running several commands with sudo already, enabling multiverse with add-apt-repository as shown here is handy, as is the link to a blog post with more details (unless some of the info there is wrong, but then I would've expected people to comment about it rather than just downvoting this and voting to delete it). If there's something wrong with this post that I haven't noticed, I hope someone comments. – Eliah Kagan Oct 3 '17 at 12:20
1

Dealing with this for awhile. Used GUI to download the Steam Client. Once I did that it installed a bunch of missing dependencies. Once I tried sudo apt-get install steamcmd again it worked flawlessly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.