3

I launch LibreOffice base, create a new base, use all the default (HSQLDB), just click next, OK, chose a file name, click OK, and it crashes.

soffice.bin crashed with SIGSEGV

It is a 32-bit machine, It crashes with 16.04 (tried OpenJDK 8.131 and Oracle Java 8.144 and tried updating LO to latest version), it crashes also with the newest 17.04, fully updated.

I tried on a physical machine and on another one in VirtualBox.

It does not crash using a 64bit install.

Any hint??

3

I finally found some info. Issue started mid June 2017.

  • LibreOffice Base does not work on a 32 bit Linux machine
  • It should be fixed with a new kernel release (hopefully)
  • It is a change in the kernel (security fix) that affected Java that is required for LibreOffice Base
  • Neither Ubuntu or LibreOffice or OpenJDK can fix this kernel issue (OK, maybe OpenJDK could also fix it)
  • There IS a workaround (tested on 16.04 and 17.04): "Add kernel parameter stack_guard_gap=1"

Edit the file /etc/default/grub and change the line beginning GRUB_CMDLINE_LINUX_DEFAULT to include the parameter, for example after your edit it may look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash stack_guard_gap=1"

then run sudo update-grub and reboot.

You should remove this parameter when the new kernel solve the issue (test), because I guess is it less secure without stack_guard ...

References:

Looks like I cannot post more than 2 Links here. But complete answer is here at ask.libreoffice.org.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.