0

The last two releases of Chrome for my Ubuntu 16.10 have had slow video playback in Chrome only on the external monitor only when fullscreen and only when that chrome window/tab is NOT focused (i.e. if I click another window on the laptop monitor the video plays fine full screen on the external monitor).

When the video is jerky I notice the Xorg process uses 100% CPU. When I click on another window on the other monitor the video plays fine and the XOrg CPU drops right off.

Not the end of the world but annoying having to always move the mouse off the screen and click a random window on the laptop monitor when trying to watch a movie!

$ sudo lshw -class display
  *-display                 
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:28 memory:c1000000-c13fffff memory:b0000000-bfffffff ioport:4000(size=64) memory:c0000-dffff

About Ubuntu reports Intel® Ivybridge Mobile

I ran Intel Graphics Tool Update and have ensured I am running the latest Chrome v60.0.3112.90 (Official Build) (64-bit)

I have tried the answer here: Chrome running slow in fullscreen mode (not Flash related) to no avail.

Chrome chrome://gpu/ outputs:

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
CheckerImaging: Disabled
Flash: Software only, hardware acceleration unavailable
Flash Stage3D: Software only, hardware acceleration unavailable
Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
Compositing: Software only, hardware acceleration unavailable
Multiple Raster Threads: Enabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Rasterization: Software only, hardware acceleration unavailable
Video Decode: Software only, hardware acceleration unavailable
Video Encode: Software only, hardware acceleration unavailable
WebGL: Hardware accelerated but at reduced performance
WebGL2: Unavailable
Driver Bug Workarounds
adjust_src_dst_region_for_blitframebuffer
clear_uniforms_before_first_program_use
decode_encode_srgb_for_generatemipmap
disable_framebuffer_cmaa
dont_remove_invariant_for_fragment_input
force_cube_map_positive_x_allocation
force_int_or_srgb_cube_texture_complete
init_texture_max_anisotropy
regenerate_struct_names
remove_invariant_and_centroid_for_essl3
scalarize_vec_and_mat_constructor_args
disable_software_to_accelerated_canvas_upgrade
Problems Detected
ATI/AMD cards with older drivers in Linux are crash-prone: 71381, 76428, 73910, 101225, 136240, 357314
Disabled Features: flash_stage3d, gpu_compositing, panel_fitting, flash3d, gpu_rasterization, accelerated_2d_canvas, accelerated_video_decode, webgl2, accelerated_webgl, flash_stage3d_baseline, accelerated_video_encode
Accelerated video decode is unavailable on Linux: 137247
Disabled Features: accelerated_video_decode
Accelerated video encode is unavailable on Linux
Disabled Features: accelerated_video_encode
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Linux AMD drivers incorrectly return initial value of 1 for TEXTURE_MAX_ANISOTROPY: 348237
Applied Workarounds: init_texture_max_anisotropy
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
Linux AMD drivers handle struct scopes incorrectly: 403957
Applied Workarounds: regenerate_struct_names
Linux ATI drivers crash on binding incomplete cube map texture to FBO: 518889
Applied Workarounds: force_cube_map_positive_x_allocation
Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
Applied Workarounds: disable_framebuffer_cmaa
adjust src/dst region if blitting pixels outside read framebuffer on Linux AMD: 664740
Applied Workarounds: adjust_src_dst_region_for_blitframebuffer
AMD drivers in Linux require invariant qualifier to match between vertex and fragment shaders: 659326, 639760
Applied Workarounds: remove_invariant_and_centroid_for_essl3, dont_remove_invariant_for_fragment_input
Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
Decode and Encode before generateMipmap for srgb format textures on Linux AMD: 634519
Applied Workarounds: decode_encode_srgb_for_generatemipmap
Software to Accelerated canvas update breaks Linux AMD: 710029
Applied Workarounds: disable_software_to_accelerated_canvas_upgrade
Force integer or srgb cube map texture complete on Linux AMD: 712117
Applied Workarounds: force_int_or_srgb_cube_texture_complete
Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
Disabled Features: native_gpu_memory_buffers
Checker-imaging has been disabled via finch trial or the command line.
Disabled Features: checker_imaging

Any advice much appreciated.

7
  • Chrome dropped pepperflash in favor of html5 starting with ver 59. I rolled back to ver 56 because of video playback issues associated with this switch
    – ravery
    Aug 7, 2017 at 16:34
  • Thanks for the info. I tried to install pepperflash manually and now chrome://flash displays: Google Chrome 60.0.3112.90 () OS Linux Flash plugin 26.0.0.137 /home/<home>/.config/google-chrome/PepperFlash/26.0.0.137/libpepflashplayer.so but fullscreen playback just on the external monitor and just when the window IS focused is as jittery as before. Is my only option to revert to v56? Thanks!
    – twiz911
    Aug 9, 2017 at 10:26
  • @ravery do you have any ideas? thanks for your time.
    – twiz911
    Aug 14, 2017 at 1:34
  • no I don't, I just know on mine the change to ver59 caused video issues, especially when more than one was playing. reverting to 56 fixed it. you may have a different issue
    – ravery
    Aug 14, 2017 at 3:35
  • Ok thanks I've been playing around with different settings and versions of flash but not been able to fix it (I think I've made the video performance worse). So it really seems the only way is to downgrade :(
    – twiz911
    Aug 28, 2017 at 13:25

1 Answer 1

0

This is due to Chrome v59+ removing flash from Chrome.

After lots of trial and error the easiest way I found was to install Google Chrome Beta to use for flash and use Chrome stable for everything else.

I downloaded and installed this .deb file: http://sagasl.uccuyosl.edu.ar/mirror/dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-beta/google-chrome-beta_58.0.3029.81-1_amd64.deb

Then launch via

 google-chrome-beta

Then go to chrome://flags/

And disable

Prefer HTML over Flash Mac, Windows, Linux, Chrome OS 
Prefer HTML content by hiding Flash from the list of plug-ins.
# prefer-html-over-flash

Then relaunch.

And now videos should play full speed full screen without jittering using good(!) old flash.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .