8

APT has me stunned from time to time. Two weeks ago I did an apt update followed by apt upgrade and was offered the 3.13 kernel even though I'm on 4.4. I ignored that. A week later I re-ran update and upgrade and NO upgrades were suggested. Today, the 3.13 suggestions are back. What's up with this and how do I prevent these retro kernels from being suggested?

lsb_release -d
Description:    Ubuntu 14.04.5 LTS

uname -a
Linux cahl 4.4.0-78-generic #99~14.04.2-Ubuntu SMP Thu Apr 27 18:49:46 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  flow-tools libdbi1 librrd4 linux-headers-3.13.0-112
  linux-headers-3.13.0-112-generic linux-headers-3.13.0-119
  linux-headers-3.13.0-119-generic linux-headers-3.13.0-121
  linux-headers-3.13.0-121-generic linux-headers-3.13.0-123
  linux-headers-3.13.0-123-generic linux-headers-3.13.0-125
  linux-headers-3.13.0-125-generic linux-headers-4.4.0-79
  linux-headers-4.4.0-79-generic linux-headers-4.4.0-81
  linux-headers-4.4.0-81-generic linux-headers-4.4.0-83
  linux-headers-4.4.0-83-generic linux-headers-4.4.0-87
  linux-headers-4.4.0-87-generic linux-image-3.13.0-112-generic
  linux-image-3.13.0-119-generic linux-image-3.13.0-121-generic
  linux-image-3.13.0-123-generic linux-image-3.13.0-125-generic
  linux-image-4.4.0-79-generic linux-image-4.4.0-81-generic
  linux-image-4.4.0-83-generic linux-image-4.4.0-87-generic
  linux-image-extra-3.13.0-112-generic linux-image-extra-3.13.0-119-generic
  linux-image-extra-3.13.0-121-generic linux-image-extra-3.13.0-123-generic
  linux-image-extra-3.13.0-125-generic linux-image-extra-4.4.0-79-generic
  linux-image-extra-4.4.0-81-generic linux-image-extra-4.4.0-83-generic
  linux-image-extra-4.4.0-87-generic linux-tools-3.13.0-112
  linux-tools-3.13.0-112-generic linux-tools-3.13.0-119
  linux-tools-3.13.0-119-generic linux-tools-3.13.0-121
  linux-tools-3.13.0-121-generic linux-tools-3.13.0-123
  linux-tools-3.13.0-123-generic linux-tools-3.13.0-125
  linux-tools-3.13.0-125-generic
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  linux-headers-3.13.0-126 linux-headers-3.13.0-126-generic
  linux-image-3.13.0-126-generic linux-image-extra-3.13.0-126-generic
  linux-tools-3.13.0-126 linux-tools-3.13.0-126-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic linux-libc-dev
  linux-tools-common linux-tools-generic
6 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 62.8 MB of archives.
After this operation, 274 MB of additional disk space will be used.
Do you want to continue? [Y/n]

ls /etc/apt/sources.list.d/
chris-lea-node_js-trusty.list       george-edison55-cmake-3_x-trusty.list       insync.list.save                      ubuntu-toolchain-r-test-trusty.list.save  webupd8team-java-trusty.list
chris-lea-node_js-trusty.list.save  george-edison55-cmake-3_x-trusty.list.save  jtaylor-ipython-trusty.list           ubuntu-x-swat-x-updates-trusty.list.BAK   webupd8team-java-trusty.list.save
cuda-8-0-local-ga2.list             google-chrome.list                          jtaylor-ipython-trusty.list.save      ubuntu-x-swat-x-updates-trusty.list.save  webupd8team-y-ppa-manager-trusty.list
cuda.list                           google-chrome.list.save                     michael-astrapi-ppa-trusty.list.save  virtualbox.list                           webupd8team-y-ppa-manager-trusty.list.save
13

You are using a HWE kernel version, but you still have a meta package pointing to the 3.13 kernel. Ubuntu 14.04 was initially released with the 3.13 kernel.

Now you are getting updates for both the 3.13 and 4.4 kernels.

If you don't want to get the 3.13 updates, remove meta packages by running

sudo apt-get remove linux-image-generic linux-headers-generic linux-tools-generic

You will get updates for the 4.4 kernel by linux-image-generic-lts-xenial and linux-headers-generic-lts-xenial meta packges.

You can also remove all 3.13 image, headers and tools packages if you like.

| improve this answer | |
  • Thanks for the answer. It solved the problem. Follow-up question, you can see from the removable list that I have "4.4.0-87" kernel image and headers lying around but my current kernel is 4.4.0-78, which appears to be a lower version, and no update suggested. Any idea why a higher version kernel looks to have been present and why it, or a more recent kernel, isn't being suggested to me by apt upgrade? Thanks again. – larkin Aug 7 '17 at 14:29
  • If the answer was helpful, accept it. If you have another question, you can ask it. How to Ask – Pilot6 Aug 7 '17 at 14:31
  • did you mean linux-headers-generic-lts-xenial with an x in the word linus? – wha7ever Aug 8 '17 at 13:07
  • Exactly, thnx. I fixed it. – Pilot6 Aug 8 '17 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.