1

I have a new installation of Ubuntu 16.04 Server 64-bit. I am trying to setup a basic kubernetes environment using conjure-up.

First of all, I have installed conjure-up via snap as instructed on the Ubuntu documentation: https://docs.ubuntu.com/conjure-up/en/:

sudo snap install conjure-up --classic

It seems to go fine with the following message:

2017-08-07T07:53:04+03:00 INFO cannot auto connect core:core-support-plug to core:core-support: (slot auto-connection), existing connection state "core:core-support-plug core:core-support" in the way
conjure-up 2.2.2 from 'canonical' installed

Next, I run conjure-up kubernetes or even conjure-up without any params, it always fails and produces the following message:

cannot create user data directory: /home/local/DOMAIN/user/snap/conjure-up/549: Permission denied

I checked that folder and I could write into it without any problem, so I don't understand really what's going on.

Any ideas?

4

From the log message, it seems that your $HOME is mounted on a network filesystem, like NFS or CIFS.

Currently there is a known limitation with snapd, that does not allow operation in such environment.

See also Snaps with classic confinement and NFS /home.

  • 1
    I have this error and my home is on a different partition using a symbolic link. Is there a solution? – will Jan 29 at 12:33
1

I was getting the same error while attempting to conjure-up kubernetes on Ubuntu 18.04 LTS. I was able to solve this by creating a file in /etc/apparmor.d/tunables/home.d with the contents @{HOMEDIRS}+=/home/DOMAIN/ (In your case it would be @{HOMEDIRS}+=/home/local/DOMAIN/).

You'll have to sudo systemctl restart apparmor.service or reboot for the changes to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.