1

I use the gnome desktop environment, and whenever I try to open the gnome control center I get an error saying:

[INFO 18:21:22.277197] Application.vala:153: System Settings version: 2.0
[INFO 18:21:22.277282] Application.vala:155: Kernel version: 4.10.0-30-generic
[FATAL 18:21:22.327817] [GLib] g_utf8_collate: assertion 'str1 != NULL' failed
[FATAL 18:21:22.328979] [GLib] g_utf8_collate: assertion 'str1 != NULL' failed
[FATAL 18:21:22.329407] [GLib] g_utf8_collate: assertion 'str1 != NULL' failed
[FATAL 18:21:22.330073] [GLib] g_utf8_collate: assertion 'str1 != NULL' failed
[FATAL 18:21:22.330846] [GLib] g_utf8_collate: assertion 'str1 != NULL' failed
[FATAL 18:21:22.331477] [GLib] g_utf8_collate: assertion 'str1 != NULL' failed
[ERROR 18:21:22.460428] [GLib-GIO] Settings schema 'org.pantheon.desktop.gala.animations' is not installed
/usr/bin/gnome-control-center: line 20:  9675 Trace/breakpoint trap   (core dumped) switchboard $switchboard_options $requested_plug

I have tried re installing gnome control center, but it hasn't worked. How do I solve the problem? Thankful for answers.

UPDATE: this is the message from the command cat /etc/default/locale

#  File generated by update-locale
LANG="en_US.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
  • Show me the output of cat /etc/default/locale. Is this something that just started to fail for you? Do you have any other account on this system that you can log into and try this? – heynnema Aug 6 '17 at 17:56
  • @heynnema This was the first time this problem occured. I don't have any other account to log into and try this. I have updated my question to show the output of the command. – ALEX Aug 6 '17 at 18:27
  • So if you reboot, does the problem still occur? – heynnema Aug 6 '17 at 18:39
  • @heynnema the problem is still there after I've rebooted – ALEX Aug 6 '17 at 19:07
  • Temporarily disable all GNOME extensions, logout, log in, and see if that makes any difference. – heynnema Aug 6 '17 at 19:15
1

You probably installed some or all of enlightenment desktop. No guarantees, but try this:

WARNING: This could hose your system.

sudo apt purge enlightenment-desktop
sudo apt autoremove
sudo apt purge gnome-control-center
sudo apt install ubuntu-gnome-desktop
# and maybe
sudo apt install gnome-control-center

..this is the gist of what worked for me. Use at your own risk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.